Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-16-2013, 10:22 PM   #1
Junior Member
 
Join Date: Apr 2013
Posts: 10
Tow Daddy Wiring Issue

I just installed the Tow Daddy "plug and play" no splice system into my 2012 Ford Edge Toad. I understand this system activated both the turn signal light and brake light when the brakes are activated. My left side works perfect, the right side only activated the brake light. Also, when the right turn and brake are used together, I get no turn signal light. Both the Coach and Toad lights function properly other than the above issue. And, the turn signal bulb works fine when the Coach and Toad are not connect together.

Trying to get this resolved and Tow Daddy's Tech Support has not gotten back to me. Any help would be appreciated.
__________________

__________________
Scott98 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-18-2013, 07:46 AM   #2
Senior Member
 
Tiffin Owners Club
Winnebago Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 2,272
What do the lights indicate on the module? When you turn on the turn signals, do the appropriate lights light up?

I would recheck your wiring. I'm not sure the connectors used on the Fords, but if they are similar, it is possible you have something plugged in incorrectly. If someone else is available, have them check your work.
__________________
Roger & Mary
2017 Winnebago Navion 24V
2014 Tiffin Phaeton 36GH (Sold)
luvlabs is offline   Reply With Quote
Reply

Tags
wiring



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.