Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-09-2014, 09:27 PM   #1
Junior Member
Join Date: Nov 2014
Posts: 1
1997 Jamboree CSport Battery Issue

Sooooooooo we are newbies. Green as can be! A few weeks past we were given a 1997 Jamboree CSport. It is in really good condition but there has been some battery issues. Our main engine battery has been going dead. There was a huge draw we couldn't figure out, so we installed a battery disconnect until we could locate the source. Turns out the house battery is wired straight to the car batter without a stop switch. In the fuse panel by the house battery (for the fridge/tv antenna/radio) it is drawing almost 5amps. We have heard that house batteries are not suppose to be wired to the car battery. The only time they are disconnected is when the main key is in the accessory position.

Can someone out there make sense of this. It doesn't seem right for the battery to die so quickly, in like 2 days.

1timejam is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-16-2014, 01:35 PM   #2
Senior Member
Join Date: Mar 2007
Location: Virginia
Posts: 771
Where did you install the battery disconnect? Are the batteries wired together in series or parallel?

2007 Gulfstream Innsbruck 36FRS
2006 Palomino Puma 27FQ
1999 American Cruiser RE2000
rjf7g is offline   Reply With Quote
Old 11-16-2014, 09:40 PM   #3
Senior Member
wanderso's Avatar
Fleetwood Owners Club
Join Date: Nov 2011
Posts: 897
1997 Jamboree CSport Battery Issue

Something clearly is not right or has been rewired at some point. Fleetwood has wiring diagrams for this rig if you contact them. 5 amps is a pretty strong draw. You can go to the fuse block (typically in a brown or black box near the dinette that also houses the battery charger and 110 to 12 volt converter) and start testing circuit by circuit to find the offending device.

These particular charger/converters of your vintage are known for failing after x number of years, depending on the brand so that is also an item to check out anyway (albeit may have no relation to this issue)

In any case, in addition to this amp draw, it seems that there is a problem with the battery isolator or it has been removed from the system. There should be pretty much zero voltage draw from the motorhome's starter battery from the RV accessories. The isolator prevents this from being possible. Here is an example of one that is available.


You will want to contact a place like Dyers to confirm the proper one for your application.

There are great folks in this site with more seasoned experience than me who will have further insights.
History: '08 View, '05 Chinook, '01 Jamboree 24D, '78 Apache Popup, 81 Komfort Tlr,
84 Mazda B2000 'w canopy,
Tent from wedding shower in '96
wanderso is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Large power draw on chassis battery '94 Kountry Star omegacanuck Newmar Owner's Forum 54 01-31-2016 08:22 PM
1997 Battery hookup. joshproducts National RV Owner's Forum 50 11-28-2014 04:13 PM
Bounder: 1997 Bounder chassis battery installation issues clooper5269 Fleetwood Products Owner's Forum 7 06-24-2014 04:13 PM
Battery or Electrical issue rlastar Class C Motorhome Discussions 2 05-26-2014 10:22 AM
Battery issue greg-1 Newmar Owner's Forum 16 12-03-2013 05:29 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.