Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 08-31-2015, 11:24 AM   #1
Junior Member
Join Date: Apr 2014
Posts: 1
98 Minni Winni electrical problem

I am hoping there is a common thread here that I am missing?
I have a GFI in the kitchen that is dead, no power to it, the range vent controls, tank level lights, pump light and heater light not working, power is getting to the board and the pump and heater works, and the outside radio is dead. Is there something in common with these items that I am missing? The breakers and fuses at the panel are all good.

Any help would be greatly appreciated.


nosmarts is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-31-2015, 11:45 AM   #2
Senior Member
Monaco Owners Club
Freightliner Owners Club
Join Date: Mar 2015
Posts: 162
power problem

Tom i am sure you have two different issues here the gfi is 120 volt system the tank lights are usually 12 volt system radio could be ether voltage do you have a gfi in the bathroom if so try resetting it by pushing the test button then push the other button to reset best i can do with info provided Mike

lead follow or get out of the WAY
1998 HR Endeavor 5.9 Cummins
redtail is offline   Reply With Quote
Old 11-12-2015, 11:26 PM   #3
Junior Member
Join Date: Nov 2015
Posts: 13
Also if some one has changed the gfi in the bathroom they may not have hooked up the line to the kitchen
Lmhawk01 is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
I have electrical problem with my RV hyd9591 Class C Motorhome Discussions 30 08-16-2015 01:35 PM
Electrical problem yp33d Class A Motorhome Discussions 7 07-05-2015 10:29 AM
1996 Terry Electrical Problem HighKountry Travel Trailer Discussion 4 09-22-2014 10:50 AM
2004 Windsor electrical problem Jmyates Monaco Owner's Forum 4 04-18-2014 01:46 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:28 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.