Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-16-2015, 06:23 PM   #1
Join Date: Apr 2014
Location: nude jersey
Posts: 56
battery drain problems

OK,On my 2008 Four winds 31F class C my engine battery always goes dead.I drove it 400 miles and shut it off(the engine) to re-fuel and it wouldnt crank.The dealer couldnt find anything wrong and said the alternator is OK.ALSO the coach batteries are fully charged yet i cant start it with the emergency start switch .The generator will not start without a jump either.Im thinking the battery isolator might be causing the engine battery to drain.Thanks

mikhett is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-16-2015, 08:36 PM   #2
Senior Member
Shadowcatche's Avatar
iRV2 No Limits Club
Join Date: Nov 2010
Posts: 1,183
A VOM/Multimeter is your friend, start with where you do have current and follow it to where you do not. Useful for finding switches that are not working too.

Shadowcatche is offline   Reply With Quote
Old 10-17-2015, 01:04 PM   #3
Join Date: Apr 2014
Location: nude jersey
Posts: 56

I'm an electronics tech by trade but need a four winds chateau electrical print(schematic)., THOR INDUSTRIES HAS BEEN NO HELP!
mikhett is offline   Reply With Quote
Old 10-17-2015, 06:29 PM   #4
Senior Member
Campingman's Avatar

Workhorse Chassis Owner
Join Date: Nov 2009
Location: Angeles National Forest, LA Calif.
Posts: 1,098
My Fleetwood 31 m would do that on occasion. It was a loose chassis ground connection.
Mark & Carole RVM54
What a long strange trip it's been
2002 Fourwinds 5000 26Q 496 ci. Chevy towing 2004 Jeep Wrangler,2016 Starcraft AR One 18', 2016 F-150
Campingman is online now   Reply With Quote
Old 10-17-2015, 06:44 PM   #5
Senior Member
BFlinn181's Avatar

Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 12,659
I think Campingman has a good suggestion; Clean all the battery connections including ground connections. The fact that you drove 400 miles and couldn't start it really points to bad connections, especially if the 'alt' light or gauge didn't show a problem. Once you get everything cleaned up, then take voltage readings at the batteries. Start engine and get a second reading. Charging will of course be indicated by a higher voltage. Then shut down the engine and try readings again, this time on shore power. You'll soon discover if both chassis and house batteries are being charged or not.

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote

battery, problems

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting Chassis Battery Drain Questions MFortie Alpine Coach Owner's Forum 14 09-03-2015 11:17 AM
Fast Battery Drain when idle americanrasc Ford Motorhome Chassis Forum 10 07-03-2015 11:09 AM
Battery drain on 2010 Fred pokgunner Freightliner Motorhome Chassis Forum 4 03-22-2015 08:55 AM
Battery Problems jefrut iRV2.com General Discussion 12 01-30-2015 09:41 AM
2004 Allegro MH 35DA STARTER BATTERY DRAIN anderson2624 Tiffin Motorhomes Owners Forum 1 02-25-2014 09:59 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:28 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.