Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-31-2015, 09:13 AM   #1
Member
 
88keys's Avatar
 
Join Date: Jan 2013
Posts: 76
Big Delay for Control Panel "Main" to come on.

Weird.....just put in 2 brand new 6v, Interstate coach batteries, the Control Panel "Aux" button works and the "Aux" power level indicator lights up full, as it should, but, now the "Main, LP, Black, Grey" level indicators are dark/blank and take about 2 minutes before they "wake up" and come on.

The coach stairs don't come out either until the thing finally wakes up.

Any ideas ?
__________________

__________________
2009 Fleetwood Icon 24A-Sprinter Diesel
88keys is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-31-2015, 10:07 AM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,239
If it is about the same length of delay each time, it sounds like a built in feature. By delaying the load to the batteries, it's preventing arcing on the relay contacts. I'd check in your documentation or with Fleetwood to ask about it.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 05-31-2015, 10:56 AM   #3
Member
 
88keys's Avatar
 
Join Date: Jan 2013
Posts: 76
This is a new thing. The delay was not there before with the old batteries.
__________________
2009 Fleetwood Icon 24A-Sprinter Diesel
88keys is offline   Reply With Quote
Old 06-06-2015, 09:53 AM   #4
Member
 
88keys's Avatar
 
Join Date: Jan 2013
Posts: 76
One of the local service guys said it could be an electrical relay that has gone funky...it could be taking it a while to "warm up" before it functions.
Now....how to find which one ?
ugh.....digging out the manual/diagrams etc...
__________________
2009 Fleetwood Icon 24A-Sprinter Diesel
88keys is offline   Reply With Quote
Old 06-06-2015, 10:46 AM   #5
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,239
If your relays are grouped together but not clearly labeled, the way I've identified bad ones is to expose them and then have a hand or fingers on them while someone else turns on the power. You'll feel the relay tripping. You could then exchange it with a like relay to test it's the culprit. If it proves slow or bad, you'll know which one to buy.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 06-06-2015, 10:20 PM   #6
Junior Member
 
Join Date: May 2015
Posts: 14
Are both batteries fully charged?
__________________
jcebrow is offline   Reply With Quote
Old 06-07-2015, 08:51 AM   #7
Member
 
88keys's Avatar
 
Join Date: Jan 2013
Posts: 76
Yes, 2 brand new, fully charged Interstate Extreme 6v Deep Cycle....but, yet another new anomaly....yesterday, the Onan Generator would not turn over with these new batteries. I had to plug into shore power to get enough cranking power to turn it over !
These things never happened with the old Trojan batteries.
__________________

__________________
2009 Fleetwood Icon 24A-Sprinter Diesel
88keys is offline   Reply With Quote
Reply

Tags
panel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is the fuse for big slide motors located Mean1255 Palazzo Motorhomes 19 01-26-2015 08:18 AM
How does one remove the DH panel to engine? John Martine Newmar Owner's Forum 8 01-08-2015 02:31 AM
Access panel to plumbing need help Samflhomes National RV Owner's Forum 4 06-16-2014 11:53 PM
Mystery Panel Koop Alpine Coach Owner's Forum 3 02-12-2014 12:19 PM
Tilt-Up Instrument Panel or Not? '98 Pace Arrow 98FPA Fleetwood Products Owner's Forum 6 01-19-2014 07:16 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.