Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-05-2012, 07:09 PM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 2
class c onan 4000 gen

i have a 2000 minnie with an onan 4000 generator. i can start the generator (without the cab on), put a load on it (or no load), and it will run fine for about 25 mins., and then it seems to starve for fuel and then shut down. now if i run the generator and it gets to the point where it starts to surge, and i turn the cab motor on, the generator will level out and continue to run with no problems. any suggestions as to why the gen. won't stay running, unless the cab motor is running?
the carb. was replaced 6 months ago with a new one at camping world
__________________

__________________
mskog13 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-05-2012, 10:05 PM   #2
Senior Member
 
genesimmons's Avatar
 
Workhorse Chassis Owner
Join Date: Aug 2011
Location: western n.c.
Posts: 381
maybe the gas cap bad? or some other type of gas tank vent maybe?. try it next time with gas cap loose and see what happens. could be the fuel filter for the genset
__________________

__________________
07 bounder 35e/workhorse
17 jayco 29me
genesimmons is offline   Reply With Quote
Old 09-11-2012, 07:14 PM   #3
Junior Member
 
Join Date: Sep 2012
Posts: 2
tried it with the gas cap loose, no change. will continue to look for any other vent leaks. fuel filter was changed with the generator service
__________________
mskog13 is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.