Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2013, 01:50 PM   #1
Junior Member
 
Ford Super Duty Owner
Join Date: Apr 2012
Posts: 12
class c rear plus

when I plug my car dolly into my rv all lights work but the running lights, I have a set of towing lights and when I plus them in the same thing happens signal lights work, break lights and flasher work but no running lights. what should I check
__________________

__________________
freelander07 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-26-2013, 06:51 PM   #2
Senior Member
 
Murf2u's Avatar
 
Join Date: Aug 2011
Location: Near Toronto, Canada
Posts: 1,842
If it's a Ford chassis, there's a second fuse panel under the hood, it has 3 fuses for the trailer plug, left turn / brake, right turn/ brake and running lights.

I'll bet the running light fuse is blown.
__________________

__________________
Ted 'n' Laurie, plus Jackson (aka Deputy Dog, the Parson Russell Terrier 'fur kid') and, Rylie (who crossed the Rainbow Bridge June 14, 2012).
Murf2u is offline   Reply With Quote
Old 09-30-2013, 12:58 PM   #3
Junior Member
 
Ford Super Duty Owner
Join Date: Apr 2012
Posts: 12
Thanks murf 2u that was exactly the problem changed the fuse today everything is working right. Tks so much you saved me a lot of time and money as I was going to the rv shop for repair
__________________
freelander07 is offline   Reply With Quote
Old 09-30-2013, 04:56 PM   #4
Senior Member
 
Murf2u's Avatar
 
Join Date: Aug 2011
Location: Near Toronto, Canada
Posts: 1,842
Happy to help. I had that issue lots with my Ford pickups, on the duallys though they had a clever trick.

The rear fender clearance lights were powered by the trailer running lights. If the fender lights were on but not the trailer, it's wiring (plug mostly) but if the fender lights are were out too you had a blown fuse.
__________________
Ted 'n' Laurie, plus Jackson (aka Deputy Dog, the Parson Russell Terrier 'fur kid') and, Rylie (who crossed the Rainbow Bridge June 14, 2012).
Murf2u is offline   Reply With Quote
Reply

Tags
class c



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.