RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-22-2019, 12:22 PM   #1
Member
 
Join Date: May 2019
Posts: 30
Dead...I mean dead!

Hi all- just joined to ask for help. I picked up a genset generator for my rig and the wiring got crossed and I got an arcing. Got it figured out and house battery is working and sending power to the generator and the cabin. Shore power seems to work ok too.

Problem is Iíve got no power to the chassis (starting) side Not a dead battery but literally no power at all. When I hit the auxiliary start button in the cab it gives me power but when I turn the key it just clicks clicks clicks, even with a jumper connected.

Any thoughts? I tried a new brown power relay and that didn't fix it. Are my wires crossed? Bad relay somewhere?

1991 Fleetwood Jamboree E350 w/Ford 460. 2 batteries. Genset Emerald Plus 4000.
__________________

Hi-Laker is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-22-2019, 02:10 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 19,674
Dirty or loose connections.

Remove and clean them all, including the one on the engine block.
__________________

twinboat is online now   Reply With Quote
Old 05-22-2019, 09:39 PM   #3
Member
 
Join Date: May 2019
Posts: 30
Ok checked that. Not it. Any other ideas?
Hi-Laker is offline   Reply With Quote
Old 05-22-2019, 10:01 PM   #4
Member
 
Join Date: May 2019
Posts: 30
I might have to have it looked by a pro. I’m no electrician but when you have a charged chassis battery and you turn the key and there’s nada, then hit the aux power button and the dash lights, headlights and radio come on, there’s something wired wrong. I’m in touch with a mobile mechanic and I’ll see what he can do...besides charge me an arm and a leg.
Hi-Laker is offline   Reply With Quote
Old 05-23-2019, 08:29 PM   #5
Member
 
Join Date: May 2019
Posts: 30
Had it looked at and it’s all good now. Wires from the relays needed moved and made sure everything was tightened up. Having a brake job done to include master cylinder, rotors, shoes, wheel cylinders, bleeding entire system. $1,200 for all. Sound about right?

Also, need to change from the old R-12 system, which is no longer blowing cold.
Hi-Laker is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What does RV friendly mean? rvgrandma iRV2.com General Discussion 22 12-27-2008 06:45 PM
What does DW mean dnebout iRV2.com General Discussion 27 12-10-2007 10:24 AM
Does This Mean Anything To Anyone? DriVer Just Conversation 11 08-26-2007 01:49 PM
Little Things Mean A Lot DriVer Workhorse and Chevrolet Chassis Motorhome Forum 39 09-04-2006 07:47 PM
battery charging (I mean draining) lundy Alpine Coach Owner's Forum 2 04-10-2006 04:07 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×