Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-04-2008, 02:25 PM   #1
Junior Member
 
Join Date: Mar 2008
Posts: 3
My right hand turn signal has stopped, (hazard and brake lights too). Anyone had a similar experience? I have switched bulbs from left and right light cluster, and that showed the bulbs were ok since the left side works normally. I still have running lights on the right side. This past week is the first time the lights have malfunctioned. I check them before each outing. The problem is carried thru to the tow dolly with the same lights being affected on the dolly.
__________________

__________________
New Whale is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-04-2008, 02:25 PM   #2
Junior Member
 
Join Date: Mar 2008
Posts: 3
My right hand turn signal has stopped, (hazard and brake lights too). Anyone had a similar experience? I have switched bulbs from left and right light cluster, and that showed the bulbs were ok since the left side works normally. I still have running lights on the right side. This past week is the first time the lights have malfunctioned. I check them before each outing. The problem is carried thru to the tow dolly with the same lights being affected on the dolly.
__________________

__________________
New Whale is offline   Reply With Quote
Old 03-05-2008, 12:31 AM   #3
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
New Whale, welcome to iRV2.com. We are glad to have you join us here and we look forward to reading of your adventures and experiences. Have you checked the fuses for the right side turn and brake signals? If so have you checked the flasher? Do you have all read lights in the rear or are the turn signals amber? Let us know and we might be of better help. Good luck and stay safe.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 03-06-2008, 01:59 PM   #4
Junior Member
 
Join Date: Mar 2008
Posts: 3
Mike and Amy, I visited the local ford dealer on an unrelated matter, and the tech showed me some tiny 10amp fuses in the under hood fuse box, which are unique to MH applications. They are not mentioned in the ford manual. Anyway, it appears that the problem is solved based on an $.89 fuse. Thanks for writing!
__________________
New Whale is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal or Electrical Problem max49 Workhorse and Chevrolet Chassis Motorhome Forum 23 10-30-2007 04:07 PM
Turn signal problem Gary RVRoamer Freightliner Motorhome Chassis Forum 9 08-23-2007 01:14 PM
Turn signal problem Rambler1 Ford Motorhome Chassis Forum 10 07-11-2007 07:50 AM
E450 Trailer Lights, Stop Lights - no Turn Signal? Scrib Ford Motorhome Chassis Forum 2 06-04-2007 01:38 PM
Turn signal wiring problem on Wilderness Agnem 5th Wheel Discussion 18 04-28-2005 07:50 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.