Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-10-2015, 07:17 PM   #1
Junior Member
 
Join Date: Aug 2015
Posts: 10
Fuel tank issue

I have a 79 Coachmen Leprechaun with a Ford F-460. My problem is with my main tank. The aux tank works fine but when I switch to the main tank it will run for several minutes and then the engine shuts off. I have done the following.

1. Converted to an electrical fuel pump which is a year old.
2. New duel tank selector valvue.
3. Tune up.

Any help would be greatly appreciated.
__________________

__________________
rmoo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-10-2015, 10:15 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,209


When the engine shuts down, have you checked to see if fuel is present in the carb? Sounds like the tank selector valve isn't opening for the main tank. Pull the fuel line off the carb and put the end in a container and see if fuel flows on the main tank setting.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 08-10-2015, 10:19 PM   #3
Senior Member
 
CJ7365's Avatar
 
Tiffin Owners Club
Join Date: Mar 2015
Location: Southern NM
Posts: 1,522
Quote:
Originally Posted by BFlinn181 View Post


When the engine shuts down, have you checked to see if fuel is present in the carb? Sounds like the tank selector valve isn't opening for the main tank. Pull the fuel line off the carb and put the end in a container and see if fuel flows on the main tank setting.
I would do exactly as BFlinn said, and obviously if there is no fuel flow fromt the main tank you have an obstruction


How far from the aux tank is the main tank, maybe the electrical fuel pump can not pull that far.


Reread your post and saw that you replaced your selector valve...also line could be clogged or collapsing or line could have a hole so its sucking air.
__________________
2005 Tiffin Allegro Bay 37DB
W22 Workhorse Chassis 8.1 Flat Towing a 82 Jeep CJ7
CJ7365 is offline   Reply With Quote
Old 08-11-2015, 01:02 AM   #4
Junior Member
 
Join Date: Aug 2015
Posts: 10
When I installed the fuel pump both tanks worked fine for about a year and then the main tank out of the blue started acting up.. I will inspect the fuel line for any issues..
__________________
rmoo is offline   Reply With Quote
Old 08-11-2015, 09:22 AM   #5
Senior Member
 
OLYLEN's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 2,329
Fuel filter on main only? Main tank fuel cap? Cracked fuel line on main tank?

LEN
__________________
2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Old 08-11-2015, 07:32 PM   #6
Junior Member
 
Join Date: Aug 2015
Posts: 10
Thanks for all the help. I changed out the fuel filter and a hose running to my generator that was damaged and that seems to have worked..
__________________

__________________
rmoo is offline   Reply With Quote
Reply

Tags
fuel, tank



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel fill issue bobgt1 Tiffin Motorhomes Owners Forum 7 04-27-2016 05:15 PM
Fuel issue solved Elandan85 Class A Motorhome Discussions 4 07-07-2015 05:45 AM
DutchStar fuel tank and gauge lrose44 Newmar Owner's Forum 26 05-18-2015 06:18 PM
Fuel tank drain plug issues Cavecanum3 Class A Motorhome Discussions 5 09-13-2014 09:31 PM
Palazzo fuel tank and fuel gauge Deucerod Palazzo Motorhomes 14 08-20-2014 10:33 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.