Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2016, 01:15 PM   #1
Junior Member
 
Join Date: Oct 2016
Posts: 5
Generac 40G runs but no power to Class C

Purchased 2013 Freelander last week and Generac 40G ran fine and supplied power to A/C, but when we returned from our first outing with shore power, the generator would start and run okay, but no power
to plugs or appliances. I read it might be Voltage regulator, or the
transfer switch? I am guessing it will have to go into the shop.
__________________

__________________
Stanley00 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-03-2016, 01:41 PM   #2
Senior Member
 
macantic's Avatar
 
Join Date: Feb 2012
Location: Aiken,SC
Posts: 1,020
did you check the breakers on the genny?
__________________

__________________
Good Sam Life Members
Served in U.S.A.F.
macantic is offline   Reply With Quote
Old 10-03-2016, 04:04 PM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 7,284
Are you sure you have a transfer switch.

When you plugged into shore power, did you pull the shore power plug from a receptacle in the storage bay ?
__________________
twinboat is online now   Reply With Quote
Old 10-04-2016, 05:05 PM   #4
Junior Member
 
Join Date: Oct 2016
Posts: 5
Generac 40G runs but no power to Class C

I checked all the breakers inside and at the generator.

The manual references a transfer switch in the troubleshooting section needing to be set to GENERATOR instead of NORMAL, but I have yet to locat this switch.

Also, I did pull the power cord out of a receptacle on the RV when I plugged into shore power
__________________
Stanley00 is offline   Reply With Quote
Old 10-04-2016, 05:20 PM   #5
Senior Member
 
Join Date: Jul 2014
Posts: 7,284
Some RVs have automatic transfer switchs. Start the generator and it switches over.

Some have manual awitches, that you turn by hand to select, although not very common.

Then there are some that have no switch at all.
The generator output runs to a receptacal, near the power cord.
The shore cord is plugged into it, to supply power to the RV, from the generator.
When at a campground, the cord is pulled and plugged into the pedestal.

Have you plugged the cord back into the receptcal you removed it from ?
__________________
twinboat is online now   Reply With Quote
Old 10-05-2016, 08:53 AM   #6
Junior Member
 
Join Date: Oct 2016
Posts: 5
Generac 40G runs but no power to Class C

That was the issue- generator not plugged back into the vehicle. We bought this used and had no operational information other than the manual which general information at best.
Thank you!
__________________
Stanley00 is offline   Reply With Quote
Old 10-05-2016, 12:22 PM   #7
Junior Member
 
Join Date: Oct 2016
Posts: 5
Generac 40G runs but no power to Class C

Another question: is it common for the main RV batteries to augment (charge) the generator starter battery? I had turned off the main batteries by way of a Blue Sea switch since I was going to leave it stored for a couple of weeks, but the generator would not start after having the main batteries turned off. I switched the main back on and after 24 hours the generator started.
__________________
Stanley00 is offline   Reply With Quote
Old 10-05-2016, 12:30 PM   #8
Senior Member
 
Join Date: Jul 2014
Posts: 7,284
It is common for the the RV ( house ) battery to also be the generator battery.

If your storing it plugged in, leave the switch on. If not, turning the switch off is correct.

Your battery may be bad, have it tested at most auto part stores.
__________________
twinboat is online now   Reply With Quote
Old 10-24-2016, 07:32 AM   #9
Junior Member
 
Join Date: Oct 2016
Posts: 5
Battery and Generator

Hey, thanks for the information. The generator now only starts intermittently - when I push the start button it will mostly just click once. I opened the panel on the set and hit start to see that the click is the linkage to what I presume to be the choke, but not sure. My dual batteries show full and I checked with a cheap battery tester light and it shows 'good'. After reading the maint manual for the generator it might be the
voltage regulator panel - or a bad wire to same. Please let me know
if you have run into intermittent starting issues.
Thanks!
__________________

__________________
Stanley00 is offline   Reply With Quote
Reply

Tags
class c, power


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generac 40G Won't Start! KarenS144 RV Systems & Appliances 9 07-05-2014 05:11 PM
Water pump runs.... and runs....and runs tobysdad RV Systems & Appliances 8 10-19-2011 08:13 PM
Generac 40g 3,600 w MUFFLER part? ToledoCharli Class A Motorhome Discussions 3 06-06-2011 08:54 AM
Generac 40g 3,600w and 15,000btu upgraded a/c ToledoCharli Class A Motorhome Discussions 2 06-06-2011 05:29 AM
NO AC Power output from Generac generator, still runs but ... talock RV Systems & Appliances 10 12-27-2010 09:21 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.