Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-09-2012, 01:43 PM   #1
Junior Member
Join Date: Apr 2012
Posts: 3
Lightbulb hood vent not venting

Hi all,

I just recently purchased a 2008 JAYCO MELBOURNE 29D and the other day was boiling water and noticed with the hood vent running that the steam was coming out from under the hood. Well...................on further investigation, I found that the fan was wired wrong and turning the wrong way. You could look at the flapper door on the vent and it would not move when you turned it on. The first thing I tried was reversing the fan blade, but that did nothing to help, so I cut the wires and wired white to black and black to white and presto.............IT VENTS LIKE NEVER BEFORE. The flapper is forced wide open.

I just wonder how many people are running around with a vent hood that sounds like its working but isn't??

Anyone else out there got this problem or had this problem and fixed it?

Its a stainless steel hood vent. I don't see a brand name on it.

Hope this helps others.


kurtwm is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-10-2012, 12:29 AM   #2
Senior Member
Join Date: Jul 2011
Posts: 918
Yep, you fixed it the right way. A lot of errors are made at the factory in the construction of RVs and TTs. Good job on finding this one.

2004 Tiffin Allegro 27.5 ft. P32 18,000 lb GVW. 8.1 liter. Workhorse chassis built May 2002. 21,000 miles. 2012 Jeep Liberty Toad. RVi2 brake unit.
Full.Monte is offline   Reply With Quote
Old 05-10-2012, 12:48 AM   #3
Senior Member
Mr_D's Avatar
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 22,359
Yep, reversing the blade doesn't work, rewiring it does. In fact that's how a reversing switch works on a Fantastic Fan. They use a double pole double throw switch to reverse the current flow.
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '05 Odyssey
Mr_D is offline   Reply With Quote
Old 05-10-2012, 02:15 AM   #4
Moderator Emeritus
Bruce C's Avatar
Nor'easters Club
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Dec 2011
Location: NH
Posts: 5,100
I had the same thing happen on my old class a. I had a new blower motor installed [heater]. Left for Florida [Dec.] and froze all the way down. Had to run the furnace's No heat, ice on the inside windows. The blower motor was wired wrong. I always recheck work done on my coach now.
Bruce & Nancy
FMCA F280542
2004 Bounder 35E
US Navy Vet.
Bruce C is offline   Reply With Quote
Old 05-10-2012, 03:11 AM   #5
Senior Member
Join Date: Sep 2007
Location: texas
Posts: 2,225
mine was wired wrong also
whem2fish is online now   Reply With Quote
Old 05-12-2012, 03:36 PM   #6
Senior Member
larrydp's Avatar
Join Date: Aug 2010
Location: Jackson, MS
Posts: 230
Boil Water???????? my DW doesn't think that can or should happen when we are in our RV.........!!!!!!!!!!!!! HA

Larry, Alice, and Halle (part-time watch dog)
Grayhawk 31 SS
larrydp is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:30 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.