Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-03-2016, 08:43 AM   #1
Junior Member
 
Join Date: Jun 2016
Posts: 2
Low voltage error - Generator won't kick on

hi, I am a first time RV owner with a 2015 Class C Thor Toyhauler. Something is sucking my voltage, but I cannot figure out what it is. All appliances/radio are off. I get a "low voltage" error when I try to raise or lower jacks. Now my generator won't start unless I first turn on the truck motor. I also get a red beep (alarm?) for Propane when I first turn on Generator, but all connections seem secure and the tank is full.

Any and All feedback would be most appreciative.
__________________

__________________
asoler is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-03-2016, 02:01 PM   #2
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by asoler View Post
hi, I am a first time RV owner with a 2015 Class C Thor Toyhauler. Something is sucking my voltage, but I cannot figure out what it is. All appliances/radio are off. I get a "low voltage" error when I try to raise or lower jacks. Now my generator won't start unless I first turn on the truck motor. I also get a red beep (alarm?) for Propane when I first turn on Generator, but all connections seem secure and the tank is full.
Any and All feedback would be most appreciative.
asoler
I suspect your house batteries are weak, failing or shot.
Have them load tested.
See: How to Perform Open Voltage Testing on Your RV Batteries
Mel
'96 Safari
__________________

__________________
mel s is offline   Reply With Quote
Old 06-03-2016, 02:05 PM   #3
Community Administrator
 
Clifftall's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 29,114
Quote:
Originally Posted by mel s View Post
asoler
I suspect your house batteries are weak, failing or shot.
Have them load tested.
See: How to Perform Open Voltage Testing on Your RV Batteries
Mel
'96 Safari

I agree with this assessment.
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
Clifftall is offline   Reply With Quote
Old 06-03-2016, 02:07 PM   #4
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,211


I'd also clean and check all battery connections, including ground connections. Make sure any lights in compartments are off, TV antennae amplifier off, etc. You could pull all the fuses and test to see which one is drawing power.

In general, if the RV is parked more than a few days, disconnect or use a battery disconnect switch or plug in to shore power. There are many small draws of battery power, from radio and engine computer memory, CO/LP detectors, etc.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LCI Low Voltage Error Roada Class A Motorhome Discussions 4 05-04-2016 10:20 AM
AGS start voltage vs Low Voltage Cutoff pilotspike Newmar Owner's Forum 8 04-25-2016 11:06 AM
Idle won't kick Off/Down spritz Vintage RV's 10 04-28-2015 10:56 AM
Battery Voltage Sag and Low Voltage Cutoff Pullin' Chocks RV Systems & Appliances 8 08-19-2014 11:46 PM
Battery Voltage How Low is TOO LOw??? Latitude MH-General Discussions & Problems 5 01-08-2008 03:11 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.