Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-19-2007, 06:39 PM   #1
Junior Member
 
Join Date: Jun 2007
Posts: 11
Well hello Im new to RV and have a 1979 Itasca suncrusier.So Im off to a bad start and feelin down.I was half mile from home and RV died tried to restart battery dead well put in new charged batt and still would not start.Put 7 gallons in tank thinking out of gas.Still nothing.put some gas in carb and my rig would fire but not stay running.Have 454 chevy motor and it has modified fuel pump which is electric.Can hear pump running when key is turned but still no gas to motor.Also the generator doesnt start either when it did when I picked it up.Wanted to try my First RV stop with family this weekend we were so excited but this a complete buzzkill.Thanks broken hearted RV owner.
__________________

__________________
geeksquad21 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-19-2007, 06:39 PM   #2
Junior Member
 
Join Date: Jun 2007
Posts: 11
Well hello Im new to RV and have a 1979 Itasca suncrusier.So Im off to a bad start and feelin down.I was half mile from home and RV died tried to restart battery dead well put in new charged batt and still would not start.Put 7 gallons in tank thinking out of gas.Still nothing.put some gas in carb and my rig would fire but not stay running.Have 454 chevy motor and it has modified fuel pump which is electric.Can hear pump running when key is turned but still no gas to motor.Also the generator doesnt start either when it did when I picked it up.Wanted to try my First RV stop with family this weekend we were so excited but this a complete buzzkill.Thanks broken hearted RV owner.
__________________

__________________
geeksquad21 is offline   Reply With Quote
Old 06-19-2007, 07:32 PM   #3
Moderator Emeritus
 
TXiceman's Avatar


 
Vintage RV Owners Club
Texas Boomers Club
Oklahoma Boomers Club
Ford Super Duty Owner
Join Date: Aug 2000
Location: Full Time, TX Home Base
Posts: 17,150
Blog Entries: 21
First welcome to IRV2. Sorry you are off to a rough start with your new adventure.

Can you disconnect the fuel pump outlet and see if it is actually pumping. If it is, move to the engine and disconnect it at the carb and run a hose to a bucket. Have someone turn on the fuel pump and time how much fuel it pumps in say 30 seconds. I don't know the fuel volume the pump should make.

Can you look down the carb and see if it is actually getting fuel into the throttle section.

Make sure there is not one or more fuel filters that might need to be changed.

Hope this helps.

Ken
__________________
Amateur Radio Operator (KE5DFR)|Full-Time! - 2012 6.7L Ford Crew Cab Dually -2013 HitchHiker Champagne 38RLRSB - Travel with one Standard Schnauzer and one small Timneh African Gray Parrot
TXiceman is offline   Reply With Quote
Old 06-20-2007, 05:20 PM   #4
Member
 
Komvee's Avatar
 
Join Date: Jun 2007
Posts: 66
That's a strange one being that the generator is it's own subsystem and it too won't start.

Hang in there, you'll figure it out!
__________________
-- Warren
Winnie Sightseer 30B
Komvee is offline   Reply With Quote
Old 06-20-2007, 06:26 PM   #5
Moderator Emeritus
 
TXiceman's Avatar


 
Vintage RV Owners Club
Texas Boomers Club
Oklahoma Boomers Club
Ford Super Duty Owner
Join Date: Aug 2000
Location: Full Time, TX Home Base
Posts: 17,150
Blog Entries: 21
The generator is usually on it's own pick up tube and will not run if you are below 1/4 tank of fuel.

Ken
__________________
Amateur Radio Operator (KE5DFR)|Full-Time! - 2012 6.7L Ford Crew Cab Dually -2013 HitchHiker Champagne 38RLRSB - Travel with one Standard Schnauzer and one small Timneh African Gray Parrot
TXiceman is offline   Reply With Quote
Old 06-20-2007, 07:02 PM   #6
Senior Member
 
Skip- Kerrville, TX's Avatar
 
Join Date: Aug 2003
Location: Ingram, TX
Posts: 310
Hi and welcome to iRV2, Geeksquad. Had the Suncruiser been sitting for awhile before you tried to drive it home? If so it is possible that the gas is old, and also contaminated. You may need to drain and flush the tank, replace the gas and the fuel filters. You may also have a carburator problem.

I imagine the generator quit because the pick-up is raised (as previously mentioned) in order to prevent one from running the tank empty while dry camping.

The good news is: you know it runs! So this is a bump in the road that is definitely fixable..
__________________

__________________
If interested, come visit us in the iRV2 Chatters chat room. We're there just about every evening from about 8:30pm eastern until about 10:00pm. It's a great bunch of folks!

Skip- Kerrville, TX is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Be a TIFFIN owner or Newmar Owner??? VACMAN Tiffin Motorhomes Owners Forum 23 11-02-2009 03:09 PM
Second Owner disup Class A Motorhome Discussions 13 04-12-2009 09:02 AM
Who is the New Owner[s] read & learn Just Conversation 3 09-11-2008 09:28 AM
Hello from a new owner buckeyes Monaco Owner's Forum 10 08-08-2007 08:11 AM
new owner jerry and toni smith Alpine Coach Owner's Forum 10 04-18-2006 04:53 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.