Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-19-2011, 05:54 PM   #1
Junior Member
 
abecar9's Avatar
 
Join Date: Dec 2011
Location: Atlanta,Ga.
Posts: 26
New to RVing

I just purchased my first motorhome,its a 1998 ford V10 cab with a coachman Santara camping area. I did a trial run in my backyard to get familiar with it.ALL works fine but now I don't have my running lights working,brake lights yes turn signals yes headlights yes front signals yes.Just the running lights around the top and couple on the side. Any hints of what could have went wrong? Fuses good/ Thanks in advance for any troubleshooting advice. Abecar9
__________________

__________________
abecar9 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-19-2011, 06:38 PM   #2
Senior Member
 
sdennislee's Avatar


 
Monaco Owners Club
Winnebago Owners Club
Join Date: Sep 2011
Posts: 6,404
Could be as simple as the bad bulbs if you've checked the fuses. Try pulling the cover of on that is not working and check for 12 volts with multimeter.
__________________

__________________
US Navy Vet, Liberty Tree Member of Oath Keepers, NRA & VFW Life Member, Alaska EMT.
2009 Safari Cheetah 40 SKQ
2009 Winnebago Chalet 231CR
sdennislee is offline   Reply With Quote
Old 12-20-2011, 03:55 AM   #3
Junior Member
 
MarlonMaine's Avatar
 
Join Date: Dec 2011
Location: Maine
Posts: 8
Send a message via Skype™ to MarlonMaine
I agree with SDennislee and you also may need to clean each light bulb ternimal then insert new bulbs.
Good Luck
MarlonMaine
__________________
MarlonMaine is offline   Reply With Quote
Old 01-21-2012, 10:06 AM   #4
Junior Member
 
abecar9's Avatar
 
Join Date: Dec 2011
Location: Atlanta,Ga.
Posts: 26
Thank you fellow campers it was just you thought, but sad part was 2nd to the last one was the culprit. all good now thanks a million...
__________________
abecar9 is offline   Reply With Quote
Old 01-27-2012, 02:33 PM   #5
Senior Member
 
Join Date: Feb 2011
Location: Oregon
Posts: 209
While your up there make sure the clearance lights are properly sealed -- Class C's are notorious for cab over leaks and many of them come from clearance lights.
__________________
ksg5000 is offline   Reply With Quote
Old 01-27-2012, 02:43 PM   #6
Senior Member
 
Steve N Sal's Avatar
 
Newmar Owners Club
Workhorse Chassis Owner
Join Date: Oct 2007
Location: Michigan
Posts: 5,614
Welcome to the forum and sure glad you solved your issues with the lights. Hope you enjoy your time on the site. Enjoy your future travels, be safe and Happy Motoring!!!
__________________

__________________
Steve & Sally / HiTee & Hudson Our Little Poms / Heidi & Houston Forever in our Hearts
04 NEWMAR MACA 3778 W22 / 05 PT Vert
Michigan (Summer) Michigan (Winter For Now)
Steve N Sal is offline   Reply With Quote
Reply

Tags
rving



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My experience, RVing full & part time & weekends, w/costs & other problems DougCP iRV2.com General Discussion 2 07-11-2011 09:30 AM
New to This Group - Old to RVing kelliepoodle New Member Check-In 6 09-22-2010 07:56 PM
What got you started into RVing and kept you here. Dogman635UT iRV2.com General Discussion 37 07-19-2009 10:36 PM
RVing Outpost Marks First Anniversary DriVer New Member Check-In 6 07-16-2006 01:11 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.