Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-06-2014, 08:33 AM   #1
Member
 
Join Date: Aug 2013
Location: Colorado
Posts: 48
Parasitic Draw on Chassis Battery

Hi all,
I took a reading on my battery and it slowly crept up for around 10 minutes and finally capped at 689ma. Does that seem pretty normal? Just curious if anyone else has taken the reading on their class c before.
Thanks,
Val
__________________

__________________
simtec820 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-06-2014, 09:02 AM   #2
Senior Member
 
al2ride's Avatar
 
Join Date: Jan 2014
Posts: 1,278
.6 Amps is not much, considering you are powering a few things like your CO2 sensor along with whatever devices are being fed directly from the battery. You could have a light on somewhere too. Have you tried the battery disconnect and then take the reading?
__________________
USAF Veteran
2014 Forest River Georgetown 351DS
2014 Jeep Wrangler Unlimited Rubicon Toad
al2ride is offline   Reply With Quote
Reply

Tags
battery, chassis



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Large power draw on chassis battery '94 Kountry Star omegacanuck Newmar Owner's Forum 54 01-31-2016 09:22 PM
Chassis battery isolators dscotty99 National RV Owner's Forum 1 04-11-2014 12:59 PM
Battery Disconnect - Does not work redbaron73 Newmar Owner's Forum 6 02-23-2014 11:27 AM
Flashing Battery Light DonL Spartan Motorhome Chassis Forum 1 01-16-2014 04:58 AM
Chassis battery charge ddgilmore Entegra Owner's Forum 22 10-17-2013 05:09 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.