Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 08-02-2014, 07:12 PM   #1
Junior Member
Join Date: Aug 2014
Posts: 2
Running light issue

I have a 1994 Santara class c. My running lights do not work. I have checked all the fuses as well as had it looked at by a moble RV guy. Turn signals and brake lights work as well as head lights and only the marker lights in the front. No other tail lights or marker lights. The only thing the moble guy thought was the switch. I did that and nothing. Any suggestions? Tom

Wettdogz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-03-2014, 12:59 AM   #2
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,954
Welcome to iRV2.
Front and rear park light would work on a common out put from the switch, Front and rear marker lights are probably spliced in to those circuits.
What chassis is your coach built on , Chev? Ford?
Getting a chassis wiring diagram may help. At least you can get a wire color to trace it down the frame rail.

99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-03-2014, 03:46 AM   #3
Senior Member
gMw's Avatar

Fleetwood Owners Club
Freightliner Owners Club
Carolina Campers
Join Date: Dec 2002
Location: Conway, SC, USA
Posts: 661
One of the motorhomes I had, a Fleetwood, had a 'hidden' fuse panel in a rear compartment with the inverter and electric cord.

An iRV2 member pointed me to it.. Not sure I would have found it on my own..

Might be worth checking around the cabinets..
George & Laraine
and The Golden Ones, Montana, Sierra & Tipper
2013 Expedition 38s, 2014 Jeep Wrangler Unlimited
gMw is offline   Reply With Quote
Old 08-03-2014, 06:18 AM   #4
Senior Member
Join Date: Aug 2011
Location: Near Toronto, Canada
Posts: 1,417
If it's a Ford chassis did you check the fuse box under the hood next to the battery?

Lots of coach builders use the trailer circuit for rear marker lights, that fuse is under the hood.

Good luck getting to it though, it's in a peach of a spot.
Ted 'n' Laurie, plus Jackson (aka Deputy Dog, the Parson Russell Terrier 'fur kid') and, Rylie (who crossed the Rainbow Bridge June 14, 2012).
Murf2u is offline   Reply With Quote
Old 08-09-2014, 06:45 AM   #5
Junior Member
Join Date: Sep 2012
Posts: 25
I just had the same problem, cound not find it, had to take it into an rv dealer who spent 7 hours location 2 shorts and having to rewire 2 sections. Expensive but they all work now. First one was in the wire that went from the tail lights to the back markers, second was in the ceiling above the dinette. Must have had a critter that was hungry!
paswigi is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alt fail light and warning light RNextPhase Monaco Owner's Forum 25 08-08-2014 08:26 AM
Running Generator and House AC on road AKJohn Class A Motorhome Discussions 55 05-24-2014 03:17 PM
No power to coach unless RV is running dvleemin Class A Motorhome Discussions 9 03-27-2014 07:33 PM
Cruise control/brake light issue datrbone8 Freightliner Motorhome Chassis Forum 5 12-13-2013 06:40 AM
LED bulb replacement issue..? (921 bulbs) Superslif RV Systems & Appliances 8 06-06-2013 08:10 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.