Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 08-26-2016, 12:24 PM   #1
Junior Member
Join Date: Sep 2014
Posts: 29
Signal Light Issues still

Hey everyone,

I'm still having issues with my signal lights blowing a fuse. Here is what I've done.

1987 Ford E350 Motorhome

Replaced all light bulbs
Check and greased all sockets
Replaced signal light switch in steering column

It will go for a random amount of time and then blow the fuse. I thought I have it fixed by disconnecting the trailer hitch wiring, but after a few months it is doing it again. Backup lights work, emergency flashers work and breaks work. Just the signals blowing fuses.

Any ideas? Its driving me nuts and probably other drivers when they randomly stop working while traveling

Thanks, Walter

whaase is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-26-2016, 05:24 PM   #2
Senior Member
Ray,IN's Avatar
Join Date: Aug 2001
Location: North America somewhere
Posts: 12,303
A signal wire intermittently shorting to ground. Have you noted which directional is on when the fuse blows?

2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA 1SG, retired;PPA,Good Sam Life member."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert theConstitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 08-26-2016, 05:34 PM   #3
Junior Member
Join Date: Sep 2014
Posts: 29
No, it never does it while I have it on. It does it randomly while driving. Yesterday it lasted less then 5 minutes on a new fuse
whaase is offline   Reply With Quote
Old 08-26-2016, 07:59 PM   #4
Senior Member
puttin's Avatar
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Dec 2009
Posts: 1,157

How do you know for sure it's a signal wire if it blows randomly? Sounds like all was well just after you disc the trailer wiring...for a while anyway. That leads me to believe the problem might be toward the rear...maybe in the vicinity of the trailer junction circuit to the rest of the mh wiring. Also, what lead you to remove that portion? When you disc it was everything weather proofed and separated from the frame? Hate to ask all this but I'm just trying to troubleshoot along with you.
puttin is offline   Reply With Quote
Old 08-26-2016, 08:44 PM   #5
Junior Member
Join Date: Sep 2014
Posts: 29
I know for sure because the signal lights have their own fuse. It's only that circuit. Breaks, running lights and back up light continue to work. The only reason I disconnected the trailer junction was a process of elimination. I cut the wires and electrical tape each one and then wrapped them all together. It seemed to work for a few months, but now it's doing it again.
whaase is offline   Reply With Quote
Old 08-26-2016, 08:46 PM   #6
Junior Member
Join Date: Sep 2014
Posts: 29
I'm starting to wonder if the tail lights themselves are shorting. But I also don't want to replace everything trying to find it....

whaase is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Signal Light Issues G Schulz Class A Motorhome Discussions 6 07-11-2016 07:45 AM
still havin issues with shifter handle capt mav Winnebago Industries Owner's Forum 3 08-31-2008 10:56 AM
still havin issues with shifter handle Freightliner Motorhome Chassis Forum 3 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:24 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.