Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-26-2015, 09:42 PM   #1
Join Date: Jul 2012
Posts: 57
Troubleshooting Onan 4000 Issue

A couple weeks ago I started having trouble with my generator shutting off after running for a period of time.

1st time this happened, the generator had been running for about 8 hrs with a load. After it shut down, it started up almost right away but only would run about 15-25 min before shutting down.

It was time for the 500 hr service and my fuel filter had never been changed so I figured that was the issue.

Over the next weekend, I changed the oil, fuel filter, spark plug, and planned on changing the air filter but after taking it off it was in good shape.

After the service, I ran it randomly this pass week for 30min to 1 hr each time with out any issues.

Well, this weekend I take my camper back out to the football field for a fun filled weekend of tailgating to have more issues. This time the generator ran for 2 hrs and shut off then for another 3 hrs and shut off. After the 3 hr run, it was late at night and I didn't want to deal with the issue so we went home.

This morning the generator cranked up easily and ran for over 6 hrs before it shut down. When I cranked it up again, it ran for almost 2 hrs before we went into the game.

Now my issue is what do I try next? Do I change the fuel pump since this may be a sign that it's on its last leg? Do I change the fuel pump and fuel filter (again) just in case something is clogging the filter? Or is it just bad gas? I did add 2 cans of Seafoam the time I filled up my take when I started having the issues.

RaisingCajun is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-26-2015, 09:57 PM   #2
Senior Member
genesimmons's Avatar
Workhorse Chassis Owner
Join Date: Aug 2011
Location: western n.c.
Posts: 339
Pump is failing I think'

07 bounder 35e/workhorse
07 roadtrek 170 popular
14 Thor citation
genesimmons is offline   Reply With Quote
Old 10-05-2015, 08:29 PM   #3
Junior Member
luis103's Avatar
Join Date: Oct 2015
Posts: 6
Need new pump I had the same problem
luis103 is offline   Reply With Quote
Old 10-05-2015, 08:36 PM   #4
Senior Member
Join Date: Sep 2013
Posts: 222
A friend of ours had a similar problem and worked on it for for weeks trying all the things the OP mentioned. Turns out it was a small air leak in the fuel line. Now it runs just fine. Just another suggestion and hope this helps.
Traxless is offline   Reply With Quote
Old 10-05-2015, 09:37 PM   #5
Junior Member
luis103's Avatar
Join Date: Oct 2015
Posts: 6
Troubleshooting Onan 4000 Issue

Originally Posted by luis103 View Post
Need new pump I had the same problem

Had to replace my pump failed tested it it was burned out and the pump was not that old it just waited to run out of warranty before burned out
luis103 is offline   Reply With Quote
Old 10-09-2015, 02:07 AM   #6
Junior Member
Pathfinder75's Avatar
Forest River Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: Dixon, IL
Posts: 17
I agree and would suspect the fuel pump or its controller. BUT I expect your generator Control Switch has an indicator light that flashes a fault code. This may help your search. Section 4-1 in manual.
A. 2-blinks = low oil pressure fault.
B. 3-blinks = Service Fault, press stop once for second level code. This is a two digit code. First digit is 1-5 flashes a pause then second digit 1-9 flashes. ( 3 flashes then 6 flashes = code 36) (because if the initial 3 or 4 flash codes, to prevent confusion there is NOT a second level 33 or 44 code)
C. 4-blinks = cranking exceeded 30 second without starting.
Second Level codes =12 & 13 are controller faults, 14 & 15 governor, 27 output volts, 29 batt. volts, 32 cranking speed, 35 control card, 36 fuel - tank low, filters etc., 37 Config. fault.
Good luck with you diagnosis.

2012 Coachman Leprechaun 319DSF (E450) (32ft.)
2011 Chevrolet Equinox 4-cyl. AWD - towed
Souris River Canoe leTigre Quetico 17 - for fun
Pathfinder75 is offline   Reply With Quote
Old 10-10-2015, 06:24 AM   #7
Join Date: Jul 2012
Posts: 57
To report back my progress, last weekend I changed my fuel pump, fuel filter (again), fuel line (from hard line to fuel filter, and I also installed an inline filter.

Currently we are out tailgating and we made it through the night and the gen is still running. It's been running for 14 hrs now. So I would assume my problem was the fuel pump.

Thanks for all the info!

RaisingCajun is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone Using a Wix Air Filter On An Onan 4000 ? Fourwinds28A Class C Motorhome Discussions 6 09-21-2015 10:09 AM
Onan 4000 series generator battery question ldworak Class C Motorhome Discussions 24 08-16-2015 06:43 AM
Question on Cummins Onan 4000 watt generator MDOGRADY Monaco Owner's Forum 5 04-04-2015 11:50 AM
Onan 5500KW Quietdiesel Issue topdownman Class A Motorhome Discussions 10 01-17-2015 11:33 AM
Onan 4000 air filter won't come off taigarazz MH-General Discussions & Problems 7 11-18-2014 10:01 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:27 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.