Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-23-2015, 05:36 PM   #1
Junior Member
Join Date: Dec 2014
Posts: 1
Winterizing problems

Hi everyone! We just recently upgraded from our 1990 Winnabago Warrior to a 2006 Winnabago Outlook. This is the first time we've winterized her. The old one was easy. This one, not so much! We blow out the lines using compressed air but just to be safe, we always run antifreeze through the pump to fill the lines. I primed the pump but NO antifreeze came out?? Help!!!

jdpupek is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-23-2015, 05:51 PM   #2
Senior Member
tmw188's Avatar

National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 981
Send a message via AIM to tmw188
Its going to take quite some antifreeze to push out out and replace the air with fluid. Close all fixtures and crack the furthest one first and work your way back. The pump will not compress air only fluid, so it will not shut off if there is a lot of air in the lines.

Sent from my iPad using iRV2 - RV Forum
tmw188 is offline   Reply With Quote

problems, winter

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problems randyw Newmar Owner's Forum 25 01-03-2016 06:47 AM
New Rig Problems Greg813 New Rig Show-Off! 31 12-01-2014 08:50 PM
Bounder: 2014 Refrigerator problems joegosselin Fleetwood Products Owner's Forum 13 11-21-2014 07:34 AM
Garmin 760 dezl lmt problems THERAPY GUY Newmar Owner's Forum 2 03-03-2014 12:03 PM
EGR soot cleaning to have less replacement problems tom chelbana Cummins Engines 2 02-14-2014 08:09 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:53 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.