iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Class A Motorhome Discussions (http://www.irv2.com/forums/f258/)
-   -   mh won't charge on 30 amp, only 50 amp or gen (http://www.irv2.com/forums/f258/mh-wont-charge-on-30-amp-only-50-amp-or-gen-128458.html)

andy rph 06-28-2012 04:02 AM

mh won't charge on 30 amp, only 50 amp or gen
 
mh won't charge on 30 amp. wall panel says its on 50 amp when it's plugged into 30 amp. tryed different things like unplugging, starting coach and gen. it will show 30 amp when plugged back in but starts charging, then inverter comes on and off then shows 50 amp again and charger won't turn on. works fine if plugged into 50 amp or using gen.

nightriderrv 06-28-2012 05:23 AM

It's been a while but have you tried to manualy select, the system should sense which amps your plugged in to. also is there a auto and a manual mode. please list some more info on the system

Alan_Hepburn 06-28-2012 03:59 PM

You might have a loose connection somewhere in your power line. If the monitor shows 50A when you're plugged into a 30A source then one leg of your rig is not making contact. I had a similar situation a few months back in my rig. I have an autoformer inline with my power line - one night I lost all power in half of the coach. Troubleshooting steps included unplugging from the 50A source and plugging in to the 30A source. My monitor still showed a 50A source. When I removed the autoformer from the circuit everything worked as it should. The problem ended up being the female plug on the autoformer - the contacts had loosened up so they were not making good contact with the male counterparts. I replaced that female plug and everything now works great.

wa8yxm 06-29-2012 10:28 AM

I am guessing a bad dogbone adapter (30/50)

The EMS determines if you are on 30 or 50 my measuring the voltage between L-1 and L-2,, If there is no voltage difference you are either on 30 amp, 20 amp or zero amp. (not plugged in)

if only one leg is receiving power from a defective dogbone, then there will be a voltage difference,, The EMS should know it's not enough but alas yours may be a bit low on the threshold (not really a problem)

See if you can borrow a different adapter and see if that works.


All times are GMT -6. The time now is 11:49 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.