iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Newmar Owner's Forum (http://www.irv2.com/forums/f103/)
-   -   Sirius Radio Problem (http://www.irv2.com/forums/f103/sirius-radio-problem-12963.html)

journeylad 01-22-2007 10:11 AM

I recently bought a KSDP, and ordered the Sirius radio capability. The problem with the original radio was that it would simply drop Sirius, and go to AUX or F1 or whatever. So the radio was replaced.

Same thing on the replacement -- it wouldn't hold the satellite.

So that was recently replaced, and it turns out that radio #3 is doing the exact same thing.

I'm beginning to suspect that it isn't the radio (although I'm not that big on Jensen). But does anybody have any other ideas?

journeylad 01-22-2007 10:11 AM

I recently bought a KSDP, and ordered the Sirius radio capability. The problem with the original radio was that it would simply drop Sirius, and go to AUX or F1 or whatever. So the radio was replaced.

Same thing on the replacement -- it wouldn't hold the satellite.

So that was recently replaced, and it turns out that radio #3 is doing the exact same thing.

I'm beginning to suspect that it isn't the radio (although I'm not that big on Jensen). But does anybody have any other ideas?

Frankie 01-22-2007 10:18 AM

I am assuming you have a subscription? .The radio itself does not contain the sirius componants.You should have a small box inline with sat antenna and stereo chassis.That box will have your serial number and ssn number.I would guess thats where your problem lies.Your radio might be switching over automaticly if its not reading a signal.

journeylad 01-22-2007 10:55 AM

Yes, I have a subscription.

The radio finds the signal just fine. But it will drop off after anywhere from 2 minutes up to a half hour. But it never stays locked on signal. And I'm sitting still, under a nice clear Arizona sky.

"007" 01-22-2007 11:09 AM

Is the Sirius ant fixed on roof or on dash of MH. http://irv2.infopop.cc/groupee_commo...n_confused.gif Try "find" type in sirius radio and take of check mark some discussion on signals to Sirius radio. http://irv2.infopop.cc/groupee_commo...icon_smile.gif

Frankie 01-22-2007 11:38 AM

Antenna connections and placement should be checked.sounds like something messing with your signal.Check the sirius connections from the head unit to the module,then to antenna.Some are roof mount and some are under the dash.I have tested antenna mount locations with a spare antenna.Some rv dealers have no clue about sat radio.My dealer didnt know the differance between a sat ready head unit and a sirius tuner.I chose a mobile unit and hard wired it to aux. port.

journeylad 01-22-2007 12:17 PM

Well, I just tried the "find", and went through seven pages of Sirius radio stuff -- nothing that matches this problem.

The Sirius radio capability was ordered through Newmar on the intial MH order, so I assume the antenna is in the roof, but I have no idea where. All that happens is you plug in a connector, to the back of the radio, that comes from somewhere in the dash.

Frankie 01-22-2007 02:53 PM

<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">that comes from somewhere in the dash. </div></BLOCKQUOTE>
Thats right.Find that and check connections.I do believe the fault lies in there. Its unlikely its the radio.Trace it back to a loose connector or bad antenna.

dhole 05-23-2007 09:28 AM

I am having the exact same problem with Sirius signal drop out and the radio reverting to Aux or Weather band. I was able to see my roof last weekend and it appears the satellite antenna is roof mounted just in front of the rubber whip antenna on the passenger side. I tend to suspect the connections or the quality of the receiver because we were parked stationary on Sunday morning and had Sirius on for a couple of hours with no problem. I am not confident that my dealer would know where to begin so I will probably just check the connections behind the radio (while I have it out to install the infrared steering wheel remote I just got) and leave it at that. I have an appointment at the factory in late August, so we will see how it's doing then.

Jetsmania 05-24-2007 05:17 PM

<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">I am having the exact same problem with Sirius signal drop out and the radio reverting to Aux or Weather band. </div></BLOCKQUOTE>
Hi! I am having the same problem at times. I do not believe it is a loose wire on the ant. It wuld give a "service sat" message or "call sirius". I went thru that problem awhile ago. Do you have the Visteon Radio? Paul

dhole 05-25-2007 09:57 AM

I have the Jensen VR 185 with factory installed Sirius receiver (seperate unit) and antenna.

Jetsmania 05-25-2007 04:44 PM

Hi! I thought I could help. I have no experience with the Jensen. I have been having the same problem off and on that you have. Let us know if they figure it out. Paul

GaryKD 05-26-2007 11:25 AM

Hi Ken,
I do not have Sirius. I have XM. I have installed many Sirius and XM radios in coaches.

Based on what I've experienced, the head unit is the controling "brain". Everything else just does what it is told to do via the head unit. When my XM drops the signal (valid drop) the radio just sets there until the signal is re-aquired. The clue of reverting to another audio source (AUX or F1) tells me it is not the antenna or antenna wire. My view is the head unit (for a brief moment) can't find the Sirius radio and reverts to a default audio source it can find.

For me, the bad component could be the:
1. Sirius radio
2. connection(s) or wire between the head unit and the Sirius radio
3. head unit

You can test this by tuning in Sirius radio and unplug the Sirius radio from the head unit. If the head unit changes to a known audio source, you have narrowed the defect to one of the above mentioned items.

As a double check, reattach the cable and tune in Sirius radio. Unplug the antenna wire. If the radio remains on the Sirius audio source, this would confirm the problem is one of the above mentioned items.

To narrow the problem further, reattach all antenna wires and tune in Sirius radio. Remove the power from the Sirius radio component. If the radio reverts to another audio source, the choices above are where the problem is.

Doclocke 12-01-2007 08:13 AM

Anybody who's having a problem with satellite radio is not alone.

We bought a Jayco Greyhawk motorhome one month ago, which is built on a Ford chassis. The radio is supposedly "Sirius Ready," but that's about as far as it goes. After trying dozens of times to get the radio to display the Sirius serial number so we could subscribe, but seeing it very briefly only twice, we returned the rig to the dealer. It's been there for more than two weeks now, and they apparently have no clue what to do about the problem.


All times are GMT -6. The time now is 04:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.