iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Tiffin Owner's Forum (http://www.irv2.com/forums/f106/)
-   -   turn signals, running lights, tow lights side clearance lights not working (http://www.irv2.com/forums/f106/turn-signals-running-lights-tow-lights-side-clearance-lights-not-working-194292.html)

gowhiz 02-25-2014 07:13 AM

turn signals, running lights, tow lights side clearance lights not working
 
As we are getting ready to hit the road, we discovered these items on our 2003 Phaeton are not working- the flashers do work. Because we are new to r ving and this coach, we would appreciate any insights you might have to our problem.:sad:

luvlabs 02-25-2014 08:14 AM

All of these lights are protected by chassis fuses. The location of the fuses vary by year so I can't tell you exactly where they might be. The other thing you want to do is check the bulb sockets for corrosion and the bulbs aw well. I suggest you head over to the tiffinrvnetwork.com site and ask your question there. There is a greater possibility of getting help from someone who has your year coach.

bobandshaz 02-25-2014 09:28 AM

Maybe the flasher unit?

Teacher's Pet 02-26-2014 08:02 AM

On our '06 Phaeton there is a pair of fuse/breaker boxes in the rear "inverter" compartment. The one closest to the front of the RV protect the circuits you list.
Checking out tiffinrvnetwork.com is an excellent idea for your model year.


All times are GMT -6. The time now is 12:05 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.