iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Workhorse and Chevrolet Chassis Motorhome Forum (http://www.irv2.com/forums/f22/)
-   -   Atwood LeveLegs... (http://www.irv2.com/forums/f22/atwood-levelegs-21182.html)

RobbieR 04-19-2007 07:03 PM

Does anyone else have problems with Atwood LeveLegs? When I try to put the levelegs down sometimes the Park/Neutral light on the control panel will not come on. I talked to an Atwood rep at the Stone Mountain, GA Allegro rally and he was supposed to send me a wiring diagram of the system but I never got it. Sometimes they work and sometimes they don't. Any suggestions?

'06 Allegro Open Road
'01 Toyota Highland Toad
Ultrapower upgrade
DIY CAI
DIY plug wire cooler

RobbieR 04-19-2007 07:03 PM

Does anyone else have problems with Atwood LeveLegs? When I try to put the levelegs down sometimes the Park/Neutral light on the control panel will not come on. I talked to an Atwood rep at the Stone Mountain, GA Allegro rally and he was supposed to send me a wiring diagram of the system but I never got it. Sometimes they work and sometimes they don't. Any suggestions?

'06 Allegro Open Road
'01 Toyota Highland Toad
Ultrapower upgrade
DIY CAI
DIY plug wire cooler

davebuck 04-23-2007 08:53 AM

Somtimes mine will not activate unless I step harder on the emergency brake pedal or release it and reset it. Guess it doesn't always make contact which allows the system to operate.


All times are GMT -6. The time now is 11:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.