iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Entegra Owner's Forum (http://www.irv2.com/forums/f278/)
-   -   Lost Sanicon Macerator Power (http://www.irv2.com/forums/f278/lost-sanicon-macerator-power-408657.html)

Hdmod 08-29-2018 05:54 AM

Lost Sanicon Macerator Power
 
Is the power feed for that next to the coach batteries on the rear wall of the back basement storage???

Lightning did us a lot of electrical damage Monday morning...........:sad::sad::sad:

DISH......matrix......TV's...........more to find in coming days I'm sure............

Eveyone down the block got computers fried...........

Still alive and breathing though.......Thank God:)


M

voltdoc 08-29-2018 10:18 AM

Quote:

Originally Posted by Hdmod (Post 4372099)
Is the power feed for that next to the coach batteries on the rear wall of the back basement storage???

Lightning did us a lot of electrical damage Monday morning...........:sad::sad::sad:

DISH......matrix......TV's...........more to find in coming days I'm sure............

Eveyone down the block got computers fried...........

Still alive and breathing though.......Thank God:)


M

Ugh on the lightning, glad to hear you are ok. Direct hit or from shorepower feed?

To answer your question, don't know for sure but the house battery switch/breaker area makes sense. There may be a small auto reset breaker somewhere in that area.

Did not see a breaker or fuse for the macerator on the bath G6 panel or in the left front electrical compartment.

dairy-guy 08-30-2018 06:53 AM

Our macerator is dead this morning. Used yesterday but no power today. Checked all logical locations for fuse or breaker but have not found anything yet.

dairy-guy 08-30-2018 09:54 AM

I spoke with Dan in CS this morning. He sent a wonderful Sanicon trouble shooting document. My issue turned out to be the switch. Easy fix. While following the trouble shooting steps I also found the source of my slide issue. A loose connection in the basement panel was dropping voltage to the G5 relay. Tightened the connection and slides now working! I will try and post the Sanicon document when I get better wifi

Hdmod 08-30-2018 01:16 PM

Quote:

Originally Posted by dairy-guy (Post 4374237)
I spoke with Dan in CS this morning. He sent a wonderful Sanicon trouble shooting document. My issue turned out to be the switch. Easy fix. While following the trouble shooting steps I also found the source of my slide issue. A loose connection in the basement panel was dropping voltage to the G5 relay. Tightened the connection and slides now working! I will try and post the Sanicon document when I get better wifi

That would be GREAT!!!!!

dairy-guy 08-30-2018 02:20 PM

Hdmod
If you can send me your email I should be able to forward the troubleshooting email from CS

Hdmod 08-30-2018 05:54 PM

Entegradude1965@yahoo.com

Hdmod 08-30-2018 05:56 PM

I can jump the wires at the relay and make the pump run so I believe I have a burnt-out relay it clicks with the switch on and off

50sbuckeye 01-12-2019 07:11 PM

Quote:

Originally Posted by dairy-guy (Post 4374657)
Hdmod
If you can send me your email I should be able to forward the troubleshooting email from CS



Can you send me the guide? 50sbuckeye@gmail.com. Thxs

hdgoldie 01-13-2019 11:30 AM

We'd love a copy also please. Hdgoldie@gmail.com. Thank you!

dairy-guy 01-13-2019 02:15 PM

1 Attachment(s)
Here is the Sanicon trouble shooting document I received from Customer Service. Hopefully the attachment works!

brobox 01-13-2019 03:42 PM

Thanks for posting that Jim. It answered a bunch of question about the new system I had.

ahyde 10-07-2019 04:33 PM

Just talked to CS today and he sent the pages noted above. Also said that most of the issues of a macerator not working turn out to be the relay. 961A-IC-12DM-R is the number on my unit (2016 Cornerstone) but apparently a "Standard" brand RY 116 is the same so I will be going to NAPA for a replacement. If that works, I post the part number and the price in case someone wants to put one in their spares box - I will... Wasn't fun this morning when it didn't work.
________________________
Alan
2016 Cornerstone - Fire Red.
2010 Jeep Commander toad.
2010 Monaco Dynasty - Sold
2005 Monaco Dynasty - Sold

Nowabeachbum 10-07-2019 04:45 PM

We lost the relay on our macerator. It is a cheap Chinese relay and you can replace it with any 30-40 amp 5 pole relay. I got a replacement from Entegra and it is a Hella brand so I’m guessing they have been having issues using the cheap relays so they replaced it with a quality piece. I wouldn’t worry about carrying extras, bypassing one is easy. Use a jumper wire from post 30 and 87.


All times are GMT -6. The time now is 04:02 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.