iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Newmar Owner's Forum (http://www.irv2.com/forums/f103/)
-   -   2017 Ventana - No Power on Driver's Seat (http://www.irv2.com/forums/f103/2017-ventana-no-power-on-drivers-seat-416808.html)

KarTomW 10-23-2018 05:53 PM

2017 Ventana - No Power on Driver's Seat
 
I have no power on my driver's seat after moving it all the way forward. The Passenger side works fine so the fuse should be fine. I don't see anything unusual under/behind the seat, no loose wires, no disconnected wires that would be inconsistent with the passenger seat... so.... anyone know about a wiring diagram for the seats? I see a thick orange wire going to the switch/controller inside the seat but don't see any damage or open wires there either...

wishalls 10-23-2018 06:30 PM

Driver and passenger seat have separate fuses. Check on the electrical panel under driver side front compartment

KenNJ 10-23-2018 06:33 PM

If you rotate the seat towards the kitchen area see if the power foot rest works meaning extend the foot rest out and then back in. Found if my foot rest was not fully retracted nothing worked right.

FLJOE 10-23-2018 07:42 PM

Prior to my warranty appointment at Newmar my seat stopped working a couple of times while traveling down the road. It would start working after awhile. I had the tech at Nappanee check it over and he couldn't find anything wrong. He said some models have a re-setting fuse/breaker but my model did not.

It worked okay until a run last week, then it stopped again for about an hour.

I had an initial issue with my footrest not retracting all the way but Nappanee reworked that including the switch and since then the alarm has never came on. Next time my seat completely stops working I may try to "bump" that footrest in further though.

britcon 10-24-2018 12:14 AM

May also want to ensure plug in connections under seat are tight. Cables get twisted when rotating seats

Coachmen Joe 10-24-2018 12:27 AM

Connectors could be partially seated and not locked. The movement forward might have caused it to pull on the harness and cause the connection not to make contact. I would purchase a small bag of zip ties and go check out the connections making sure nothing is strained when moved to its furthest point. If equipped with some type of foot rest look to see if there is some type of micro switch that has been activated and needs to be put back in its normal position.

wepinegar 10-24-2018 11:02 AM

I agree with the comments about the plugs - Make sure the wires coming into the plugs are pushed in all the way also - This has been and issue on the passenger seat in mine till I figured out the wires coming into the plugs from the seat were Plugged into the plug also!


All times are GMT -6. The time now is 07:42 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.