iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Tiffin Owner's Forum (http://www.irv2.com/forums/f106/)
-   -   chassis battery (http://www.irv2.com/forums/f106/chassis-battery-45306.html)

Tazz6 01-09-2008 03:35 PM

We have a 05 Tiffin Allegro Bay that the chassis battery keeps going dead. We replaced the battery a month ago because it had a dead cell. We went on 1 trip about 2 weeks ago and battery did fine. I went out to start it this weekend and it was dead. Any suggestions?

Tazz6

Tazz6 01-09-2008 03:35 PM

We have a 05 Tiffin Allegro Bay that the chassis battery keeps going dead. We replaced the battery a month ago because it had a dead cell. We went on 1 trip about 2 weeks ago and battery did fine. I went out to start it this weekend and it was dead. Any suggestions?

Tazz6

Joe-K 01-09-2008 06:19 PM

Tazz,

Welcome to iRV2.com.


Since it's the chassis battery that's going dead, it actually should narrow down what's drawing power in the rig. Typically there aren't many coach accessories that run from the chassis battery.

Have you done any trouble shooting yet on your coach? If you have access to a current meter, it would be useful to pull the negative battery cable and put the DC current meter inline between the battery post and cable you've pulled. Once you have a current draw, you can figure if it is excessive or not. Typically, the motorhome will have some parasitic current draw from the chassis battery due to the engine and transmission ECU, but I wouldn't expect the battery to go dead in a week.

If the current draw is high, begin looking for lights, radio, or other items that are turned on. If the current draw is very small and the battery isn't holding a charge, then it might be another bad battery.


All times are GMT -6. The time now is 11:07 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.