iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Class C Motorhome Discussions (http://www.irv2.com/forums/f87/)
-   -   E-450 triton parking lights wont turn off (http://www.irv2.com/forums/f87/e-450-triton-parking-lights-wont-turn-off-461813.html)

2 foot tommy 09-16-2019 10:45 PM

E-450 triton parking lights wont turn off
 
Has anyone experienced this problem? When I turn on parking lights, or headlamps when I push the switch in to turn them off, the parking lights stay on. If I unhook the batt. then hook it back up they stay off, till I pull the headlamp switch. Then they stay on again. I'm thinking headlamp switch bad? Anyone else ever seen such a thing?

avfordguy 09-16-2019 11:17 PM

What year please?

2 foot tommy 09-16-2019 11:22 PM

2006

2 foot tommy 09-16-2019 11:25 PM

sorry 2006 41k miles I had just replaced the circuit breaker for the isolator solenoid last week.

l1v3fr33ord1 09-17-2019 07:56 AM

2 foot tommy-

Some E-series motorhomes develop a short behind the headlamp housing. It appears to be related to the sheet metal that holds the housing. You might try removing both of the headlamp assemblies and looking for crushed or cut wires in the last foot of the wiring.

2 foot tommy 09-18-2019 09:29 PM

thanks for the input. I have a new head lamp switch coming in tomorrow. Because its a fast exchange I'm going to put that in. If unsuccessful I will look behind head lamps.

2 foot tommy 09-20-2019 08:16 PM

I installed new headlamp switch. Same problem, turn headlights on / turn them off, and parking lights stay on. I'm going to remove headlights tomorrow and check wires behind.

2 foot tommy 09-21-2019 09:03 PM

Parking light problem solved. Twinboat mentioned trailer light harness on a different post. So I checked it on mine. Sure enough someone prior to me had trouble with trailer lights and made a jumper wire from the wire harness for the tail lights on the coach and jumped it to the trailer wire harness. Soon as I took the wire off, it turned my parking lights off. Thanks again!

guido95 09-22-2019 10:03 AM

l1v3fr33ord1

Do you know if this short persists in newer models? I've got a 2014 where the parking lights randomly turn on. I've checked the trailer plug, that does not appear to be the culprit.

l1v3fr33ord1 09-22-2019 06:20 PM

Quote:

Originally Posted by guido95 (Post 4967000)
l1v3fr33ord1

Do you know if this short persists in newer models? I've got a 2014 where the parking lights randomly turn on. I've checked the trailer plug, that does not appear to be the culprit.

I don't know.

THenne1713 09-22-2019 11:35 PM

So now you have a tail light problem? Check fuses under hood, driver side, small red 10a

2 foot tommy 09-23-2019 03:43 PM

On my 2006 E-450 Evidently the previous owner had an issue with getting the trailer running lights to work. He went ahead and made a jumper wire from the wire harness that is for the tail lights on the MH, and jumped it to the wire harness that Ford put their for the trailer lights. It was back feeding the coach lights causing the parking lights to not turn off. There are two separate wire harness that run to the rear of the coach. One for coach tail, brake, and turn signals. One for trailer, tail, brake, and turn signals. They must be kept separate and not jumped or connected together. I assume Ford did this so a trailer light problem would not effect the operation of the coach rear lights. Correct there are separate fuses, and relays for each inside the fuse box on the drivers side under the hood.


All times are GMT -6. The time now is 05:54 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.