iRV2 Forums

iRV2 Forums (http://www.irv2.com/forums/)
-   Class A Motorhome Discussions (http://www.irv2.com/forums/f258/)
-   -   Chassis light out and engine won't start (http://www.irv2.com/forums/f258/chassis-light-out-and-engine-wont-start-462168.html)

TourRVenture 09-19-2019 01:52 PM

Chassis light out and engine won't start
 
The entry step would not come in so we checked the fuses outside the coach up on the front left and some sparks went flying and now the chassis light won't come on and the engine is dead, and suggestions?

We changed the fuses around to make sure it wasn't that and still no power/

Skip426 09-19-2019 07:05 PM

1 Attachment(s)
Do you have ANY 12 volt power from the chassis batteries to the dash of the coach ?

If the answer is no ; you have to go to the chassis batteries and follow the main +power cable, towards the frame , chances are with the first 3' of that cable you'll find a large fuse or 12 volt circuit breaker , that protects the cable that runs to the dash from shorts like you describe .
Circuit breaker may be a manual reset like this picture.

Do you have a 12 volt test light or a voltmeter ?

TourRVenture 09-20-2019 11:40 AM

Yes, we checked the continuity and there is no sign it is bad on the 300 amp fuse and it indicated it was okay. We never saw any circuit breaker like the one you displayed. We tested every fuse and still no 12V power to the dash or chassis.
2013 Winnebago Tour


All times are GMT -6. The time now is 07:31 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.