Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-24-2022, 05:40 PM   #1
Junior Member
 
Join Date: Jun 2022
Posts: 6
1997 Itasica Suncruiser 37 Slideout not working.

Hey there everyone, I am rather new to RVing, and this is my second big trip with my RV. The first time I used it, I drove from Ohio to Alaska at the end of November (bad idea I know). I had a number of electrical repairs to do on it since it came out of storage, and of all the repairs I haven't been able to fix yet is the slideout. The Jack's function correctly, albeit one is really slow and doesn't like to retract, but the slideout doesn't work at all. I've checked most of the electrical connections, but haven't had any luck yet. It sounds like the hydraulic pump activates when I engage it, and the power drops for the batteries. I'm not sure what to do now.
Dieneces is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-25-2022, 08:41 AM   #2
Senior Member
 
Lt46's Avatar
 
Winnebago Owners Club
Retired Fire Service RVer's
Join Date: Mar 2008
Location: Central Florida
Posts: 775
Let me ask the obvious, have you unlocked the slide? Second thing to check is fluid level in the pump reservoir.
__________________
Peter
1997 F53 Adventurer 37rw
IAFF L-792 (Retired)
Lt46 is offline   Reply With Quote
Old 06-25-2022, 01:51 PM   #3
Junior Member
 
Join Date: Jun 2022
Posts: 6
I did unlock the slide. I'll get back to you once I have topped off the reservoir.
Dieneces is offline   Reply With Quote
Old 06-26-2022, 08:18 AM   #4
Senior Member
 
Lt46's Avatar
 
Winnebago Owners Club
Retired Fire Service RVer's
Join Date: Mar 2008
Location: Central Florida
Posts: 775
If you access the HWH website you'll find a lot of troubleshooting pages for their hydraulic systems. You'll be needing to look at the 200 series pages. Good luck.
__________________
Peter
1997 F53 Adventurer 37rw
IAFF L-792 (Retired)
Lt46 is offline   Reply With Quote
Old 06-26-2022, 04:48 PM   #5
Junior Member
 
Join Date: Jun 2022
Posts: 6
Got the reservoir topped off, still no luck. It did take about a quart of fluid to top off though. I have been looking through the troubleshooting steps, and most of them say everything else need to be functioning correctly in order to troubleshoot correctly. An issue I am having though is the driverside front jack is not retracting fully. I haven't been able to figure that out either.
Dieneces is offline   Reply With Quote
Old 06-27-2022, 04:01 AM   #6
Junior Member
 
Join Date: Dec 2020
Posts: 16
We have a 1998 Itasca and have had the same issue twice. Boyfriend went under RV where the slide control box is and just tapped it lightly with a hammer. Corrosion on the wires or connections, anyway, this has worked for us both times. Hope it helps.
Cranelakeont is offline   Reply With Quote
Old 06-27-2022, 06:49 PM   #7
Junior Member
 
Join Date: Jun 2022
Posts: 6
So, when I had someone else operate the panel I could hear the solenoid clicking on the pump. So I know it is getting power. Not sure where to go from here
Dieneces is offline   Reply With Quote
Old 06-27-2022, 06:56 PM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 27,499
First thing would be to visit the HWH web site and look for info that will help you determine what series your system is , then you can download a free pdf users manual , that has a troubleshooting guide.

Welcome to HWH Corporation

Once you have the series # and have used the guide , re-post if you haven't found your problem .

EDIT: Never add fluid to the HWH reservoir unless the jacks are fully retracted .

Following the cleaning instructions in this pdf helped my slow retracting jack issue , but you many need new springs if cleaning doesn't help.
Attached Files
File Type: pdf HWH jack maintenance.pdf (16.1 KB, 2 views)
File Type: pdf HWH jack & spring info.pdf (8.6 KB, 2 views)
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-28-2022, 10:58 AM   #9
Senior Member
 
Lt46's Avatar
 
Winnebago Owners Club
Retired Fire Service RVer's
Join Date: Mar 2008
Location: Central Florida
Posts: 775
My passenger rear jack barely tries to retract, it's been like that for years. I've cleaned and sprayed WD40 countless times and it just does not want to cooperate. I should just replace it but instead, when
I drop the jack down, I drop it onto a 2"x4" that I use as a lever to get it to go back up. A work around for sure but it's free.
__________________
Peter
1997 F53 Adventurer 37rw
IAFF L-792 (Retired)
Lt46 is offline   Reply With Quote
Reply

Tags
slide, slideout, suncruiser



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 itasica meridian 40u mrserious iRV2 Owners Registry 0 07-11-2021 08:32 PM
Itasca Suncruiser :: 2008 Itasca Suncruiser 38T RHTUTHILL iRV2 Owners Registry 0 10-03-2016 04:44 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.