RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-21-2020, 06:23 PM   #1
Junior Member
 
jmarr1's Avatar
 
Join Date: Jan 2014
Posts: 8
2016 Winnebago Tour taillight problems

The right upper taillight has one section of LED red lights (there are 2 sets) that are not working. I purchased a new taillight which arrived today. Before hooking up the new light I tested the connections and there is power at the plug-in. Hooked up the new light and the same set of LED's are not working.
Anyone have a suggestion what to try next?
__________________
2016 Winnebago Tour 42QD
2015 GMC Terrain
jmarr1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-21-2020, 06:44 PM   #2
Senior Member
 
Ron Postma's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2006
Location: On the open road
Posts: 665
It might be the adapter box
__________________
2014 Winnebago Tour 42QD
2014 Honda CRV Toad W7REP
WiFiRanger Elite AC Pack
Ron Postma is offline   Reply With Quote
Old 09-22-2020, 10:36 AM   #3
Junior Member
 
jmarr1's Avatar
 
Join Date: Jan 2014
Posts: 8
I tested the output from the adapter box and it showed power. I did try hooking the new light up to the bottom wiring and the whole light worked so I'm thinking that the adapter box isn't giving the correct output. Thanks for responding.
__________________
2016 Winnebago Tour 42QD
2015 GMC Terrain
jmarr1 is offline   Reply With Quote
Old 09-23-2020, 05:59 PM   #4
Junior Member
 
davo54's Avatar
 
Join Date: Apr 2019
Location: Katy, TX
Posts: 17
Where did you buy your replacement taillight? I have one on my tour needing replacing.
davo54 is online now   Reply With Quote
Old 09-23-2020, 06:19 PM   #5
Senior Member
 
Ron Postma's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2006
Location: On the open road
Posts: 665
You can get them on amazon or eBay or salvage yard. They are from a 2009 Cheve Suburban or Tahoe,
__________________
2014 Winnebago Tour 42QD
2014 Honda CRV Toad W7REP
WiFiRanger Elite AC Pack
Ron Postma is offline   Reply With Quote
Old 09-25-2020, 05:26 AM   #6
Senior Member
 
SuperGewl's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Aug 2004
Location: Oregon
Posts: 2,360
When in doubt about exactly what lamp assembly you have, just take a picture, a close one, of the letters and numbers that are on it. They tell you exactly what they are from. Look around the edges of the light assembly to get the information then just do a search on the good ole internet and pow, bang whoopee.
__________________
Retired Navy Submariner
2014 Itasca Sunstar 35F; 5 Star tuned; 2014 Jeep Cherokee TrailHawk
SuperGewl is offline   Reply With Quote
Reply

Tags
ems, light, problem, problems, winnebago



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Winnebago Tour :: 2014 Winnebago Tour vtoro1 iRV2 Owners Registry 0 09-19-2019 12:11 PM
Review of my LED taillight upgrade on 2016 Vibe IronCobra Travel Trailer Discussion 5 02-16-2016 05:30 PM
Bob's 2015 GRAND TOUR vs MY 2012 Tour... same old problems despite name change! bigfeather Winnebago Industries Owner's Forum 30 12-13-2015 04:39 PM
Taillight and clearance light problems kcs81569 Gulf Stream Owner's Forum 1 11-17-2013 12:30 PM
Tour the New 2014 Winnebago Tour On American RV'er DriVer RV Industry Press 0 08-04-2013 06:54 PM


All times are GMT -6. The time now is 08:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.