Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-29-2014, 05:51 AM   #1
Member
 
Geneb1737's Avatar
 
Join Date: Aug 2013
Posts: 36
LCI Electronic Levelers

On our 3rd trip with our 2015 Itasca Sunstar 35f from Ohio to Wy we stopped at a rest stop in Indiana for lunch. When starting the engine we got the warning from the levelers to return levelers for service. Got out and there was a pool of hyd. Fluid under the coach beneath the front levelers. Called LCI tech support and they said we should not drive in this condition but should lock them up. So a call to roadside service and 375.00 dollars later we were ready to roll again. The strange thing is that we neither extended or retracted the jacks just shut down and started up. Anyone one else have this problem?
Geneb1737 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-29-2014, 09:18 PM   #2
Senior Member
 
grtharris's Avatar


 
Winnebago Owners Club
Join Date: Apr 2003
Location: Skiatook, OK
Posts: 2,512
Geneb1737, Sounds like a hose or fitting came loose. These jack require pressure to stay up. Here is a thread about jack down warning light.
http://www.irv2.com/forums/f101/lipp...ht-195397.html
__________________
Grant & Pat
2014 Adventurer 35P
Waiting on our Bad Batch Bronco to be delivered!!
grtharris is offline   Reply With Quote
Reply

Tags
levelers



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Update on my HWH Levelers myshaggydog Newmar Owner's Forum 16 06-20-2014 12:39 PM
RV levelers theory of operation? atodalen Winnebago Industries Owner's Forum 14 06-01-2014 11:24 PM
Self deployed LCI levelers update eterwilliger Class A Motorhome Discussions 3 05-24-2014 05:28 AM
New to Levelers.... MutinyGuy Class A Motorhome Discussions 4 04-13-2014 08:35 AM
LCI Levelers 2010 Challenger. needlenoses Thor Industries Owner's Forum 3 01-29-2014 06:10 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.