Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-21-2005, 04:45 PM   #1
Member
 
Join Date: Dec 2004
Location: Rochester, MN
Posts: 45
'02 Horizon, no problems. Conditions normal, got a warning light! "Low Water" with buzzer. Went under coach to look for leak ! Lost ALL antifreeze. The plastic ties that hold the antifreeze lines came loose. The antifreeze line that runs to the water jacket for the "motor aid" rubbed on the drive shaft. The source of the problem was a .04 plastic tie ! Had to replace the antifreeze line and of course the antifreeze. I did it myself and it cost $100.00. Wish now I would have (inspected) looked under there at the start of the season. 2 minutes would have saved a lot of work and a close call to damaging the engine due to overheating. Our investment is worth it ! I have had the full inspection at Freightliner 3 times and it never showed up. Now I know what to look for. Will not allow this to happen again !
__________________
Mike Lutz
Mike Lutz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-21-2005, 04:45 PM   #2
Member
 
Join Date: Dec 2004
Location: Rochester, MN
Posts: 45
'02 Horizon, no problems. Conditions normal, got a warning light! "Low Water" with buzzer. Went under coach to look for leak ! Lost ALL antifreeze. The plastic ties that hold the antifreeze lines came loose. The antifreeze line that runs to the water jacket for the "motor aid" rubbed on the drive shaft. The source of the problem was a .04 plastic tie ! Had to replace the antifreeze line and of course the antifreeze. I did it myself and it cost $100.00. Wish now I would have (inspected) looked under there at the start of the season. 2 minutes would have saved a lot of work and a close call to damaging the engine due to overheating. Our investment is worth it ! I have had the full inspection at Freightliner 3 times and it never showed up. Now I know what to look for. Will not allow this to happen again !
__________________
Mike Lutz
Mike Lutz is offline   Reply With Quote
Old 06-22-2005, 01:43 AM   #3
Senior Member
 
troth's Avatar
 
Join Date: Aug 2003
Location: NE Ohio
Posts: 1,177
Good tip Mike! It doesn't take that long to look around an engine and see which things "could be a problem" if the plastic zip ties broke.... I did the same on my 8.1 gasser in a few places. Remember to use zip ties that are UV resistant (generally not the white colored ones).
__________________
Last Brave 2004 34D
troth is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing antifreeze two sailors Alpine Coach Owner's Forum 10 01-15-2008 09:40 AM
changing antifreeze Jim Winnebago Industries Owner's Forum 1 05-14-2007 02:28 PM
changing antifreeze Jim Ford Motorhome Chassis Forum 1 05-13-2007 07:24 AM
Why no RV antifreeze?? Ron-in-Tn Winnebago Industries Owner's Forum 18 03-17-2007 11:11 AM
Capacity on Antifreeze? Mike and Claudia Newmar Owner's Forum 3 03-13-2007 02:48 AM


All times are GMT -6. The time now is 12:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.