RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-13-2019, 08:34 PM   #1
Junior Member
 
Join Date: Jul 2011
Location: Fort Myers, Fl
Posts: 9
Magnum Communication Error

We have a 2014 Suncruiser (Itasca) 38 q. My inverter flashes no communication error when traveling. The red and green light may be on, and it flashes all kinds of crazy things. It may tell me it is not communicating but the inverter may be working. It comes and goes. I'll turn it back on and it may work for a while. As soon as we come to a stand still, it will work. I have tried all of the resets and checked the cord and that does not solve the problem. It is apparent to me, there is a "short' or loose connection somewhere. Any ideas? It is a magnum inverter.

Thanks,
AnnieD
__________________

Anndrennan is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-14-2019, 10:19 AM   #2
Senior Member
 
Join Date: Aug 2018
Posts: 194
Hi Annie. I don't know about Magnum inverters, but I had numerous strange things happening with my Xantrex inverter. It uses a phone cord with those little square plugs on the end. The jack that those ends have little thin gold wires in them. What fixed my problems was gently pulling those wires up to give them more tension to contact the pads in the plug. I used a small crochet hook.
If your Magnum uses those phone cords, give it a try.
__________________

Carlos Marti is offline   Reply With Quote
Old 08-19-2019, 10:27 AM   #3
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 1,657
The Magnum remote (panel inside your RV) and the inverter communicate via what looks like a phone cable with RJ-11 jacks on both ends.

If a jack comes loose you'll get a "communication error". Of if there is a problem with the cable.

So, check both ends of those RJ-11 plugs and make sure they are properly seated. By the way, I"ve been told you can't just use a phone cord to replace those and that you have to contact Magnum to get the right cord. I don't know if it's true, that's just what I've been told.
__________________
2017 Winnebago Adventurer 37F
2016 Lincoln MKX Toad
creativepart is offline   Reply With Quote
Old 08-20-2019, 12:35 AM   #4
Senior Member
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 2,564
Ah.. Florida..

My Magnum recently went completely nuts. HV trips, randomly turning on and off, and a variety of other things (I have a list). I have a friend whose Magnum was doing the same things. Whats common? He lives near the beach, and I camp ON the beach a LOT!.. and you are the humidity capitol of the US (cept Houston).

Fix for me was to pull all the RJ-11 jacks, spray them with contact cleaner and exercise it several times. I did this with all the devices hooked to the Magnum and so-far its been good. My friends up in Oregon was the basic same issue nut he had to tear his apart and clean the ribbon cable on the control board.

Clear case of corrosion.
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 11-10-2019, 10:30 PM   #5
Senior Member
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 2,564
Well on my subscribed posts I see a response to this thread but it doesn't appear here. So to who wrote it, you MAY find contact cleaner at an auto store, donít know. What I use is a very old can of Cramlon that cost $25 20 years ago. It appears that corroded contacts is an issue in these things even though when we are at the beach, the inverter door is never open, but welcome to fresh sea air... As I exercised these connectors with Cramlon I then coated them with Dielectric grease to keep it from happening again.
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 11-12-2019, 05:28 AM   #6
Junior Member
 
Join Date: Jul 2011
Location: Fort Myers, Fl
Posts: 9
Thank you all for your responses. If only it were this simple. Inverter out and to the shop twice (Magnum authorized repair center). New control board put in. Service guy says it is working properly. RV service center says power is going in but not out. They can't seem to figure it out. Picking inverter up tomorrow for the second time - don't know what to do at this point. Seems the problem is somewhere else in the coach.
Anndrennan is offline   Reply With Quote
Old 12-15-2019, 03:02 AM   #7
Senior Member
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 2,564
Any updates on this?
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 12-16-2019, 06:01 AM   #8
Junior Member
 
Join Date: Jul 2011
Location: Fort Myers, Fl
Posts: 9
Actually - no. Inverter is working properly OUTSIDE of the motorhome. When they hook it up to test it, no issues. When they put it inside the motorhome, nope. There is power going to the inverter but not out to the motorhome. They have serviced the batteries, which are fairly new anyway, cleaned all the contacts, etc. They are scratching their heads. Three 20 year RV technician veterans can't figure it out. They have not called Winnebago because they are not an authorized Winnebago repair center so I guess I will. Not sure if they will even know. We bought this motorhome new in 2014 so it is something that has "happened" for whatever reason. Very frustrating.
Anndrennan is offline   Reply With Quote
Old 12-16-2019, 06:27 AM   #9
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 1,657
What does Magnum support say? I think I know what Winnebago will say, “take it to a WBGO dealer.” What else can they say over the phone?

When tested outside the RV are they using your RV batteries?

Do you have power throughout the coach on shore power?
__________________
2017 Winnebago Adventurer 37F
2016 Lincoln MKX Toad
creativepart is offline   Reply With Quote
Old 12-17-2019, 06:57 AM   #10
Junior Member
 
Join Date: Jul 2011
Location: Fort Myers, Fl
Posts: 9
Some really good questions. I spent hours on the phone with Magnum prior to having it serviced. They suggested I take the inverter to an authorized technician. I do know the repair shop has talked to the authorized technician several times. I'll try calling Magnum again but I am sure they will say the same thing as Winnebago. Trace the wires. In answer to your question about shore power - the last time we used it, we had shore power. It has literally been in the repair shop since the first of October. We haven't rushed it because we were not going to be using it and I think they work on it in their spare time. I will ask that question though. It all is very frustrating! I will also ask the question about using our batteries - that is a great thought! Thanks.
Anndrennan is offline   Reply With Quote
Old 01-16-2020, 01:54 AM   #11
Senior Member
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 2,564
I wish you were local so I could look at it. It is IMPOSSIBLE to feed it AC in the motorhome exactly like you did on the bench and AC not come out the other side of the inverter. Either it works or it doesnít, it is a simple relay and it could care less where it transfers power. Something else is wrong and those three knuckleheads need to find a fresh set of eyes
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 01-16-2020, 10:29 AM   #12
Senior Member
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 2,564
Hopefully they have figured this out, but if you look at the manual, the AC terminals between in and out are backwards. Itís really easy to hook incoming AC to Contact set #1, and match what you just did on the output, but itís actually contact set #2 instead. It HAS to be something that simple
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 01-17-2020, 06:05 AM   #13
Junior Member
 
Join Date: Jul 2011
Location: Fort Myers, Fl
Posts: 9
Inverter Update

I took ALL of the suggestions above to the RV Repair, they also had a tech call Magnum and Winnebago. This was after we went into the repair location and spoke with the manager who got involved and less than a week later, all resolved. Keep in mind, this unit has been there since the end of October. After exhausting every thing, Winnebago suggested a new inverter. A new inverter was installed and I was told it was working as designed. I am going to take the old inverter to the Magnum technician who luckily, will reimburse me for the new motherboard he put it. I told him he could have the inverter which he appreciated because he is totally perplexed as to why this did not work in the motorhome. This guy is very intelligent and wants to take the time to figure it out.

Anyway - we should be picking the motorhome up today so I'll let you guys know if it still doesn't work.

Thank you all for the suggestions. It sure has been frustrating and maybe just one of those flukey things. The magnum technician will let me know what he finds as we all want to know and we may never know.

Ann Drennan
2014 Itasca Suncruiser 38q
__________________

Anndrennan is offline   Reply With Quote
Reply

Tags
cat



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnum inverter MS2012--Internal bridge error message TexasTwoStep RV Systems & Appliances 1 07-28-2019 10:53 AM
Upgrading from Magnum ME-2000 MSW inverter to Magnum ME-2800 PSW inverter. Stan&Jacquie MH-General Discussions & Problems 7 11-12-2015 07:54 PM
Have brand new 2014 Phaeton with a Magnum inverter. PCS control shows "wiring error" debnjack Tiffin Owner's Forum 6 12-07-2014 08:41 AM
Tracstar 360 antena communication error Ssgritton Technology: Internet, TV, Satellite, Cell Phones, etc. 8 09-19-2013 08:44 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×