Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-27-2018, 06:18 PM   #1
Senior Member
 
Winnebago Owners Club
Join Date: Mar 2016
Location: CT
Posts: 254
Need help, coach batteries not connecting

I could use some input on this one. My coach batteries aren't charging nor will they run any of the 12V items. When plugged in to shorepower or on generator everything 12V works. Converter is putting out 13.5 roughly but it is not making it to the batteries. And my batteries tested at 12.7 so they should be able to run some LED 12V lights. The disconnect switch seems to be working. The light turns on and off and I can hear the solenoid when I press the buttons. Is it possible the MOBAC has an issue? I'm not sure how to test it. Any help is appreciated.
__________________
2010 Winnebago Vista 32K
2019 Jeep Wrangler Sahara toad
jpspaz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-27-2018, 08:20 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 19,927
If you take the large wires on the two large terminals on the battery isolation solenoid off and fasten them to one terminal, you'll bypass the solenoid. If you now have 12v power in the RV with the shore cord unplugged, you'll know it's a bad solenoid. If still no power, then look for the large amp fuse or circuit breaker in the cable between the battery and the solenoid. Check for 12v on both sides of that fuse/circuit breaker.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 03-28-2018, 07:00 AM   #3
Junior Member
 
Winnebago Owners Club
Join Date: Feb 2014
Posts: 26
Just went through that problem (a couple of times). Here are 2 links that hopefully helps.

RV lights
http://www.irv2.com/forums/f101/lights-out-362562.html

http://www.irv2.com/forums/f102/no-1...er-383911.html
ht4cae is offline   Reply With Quote
Old 03-28-2018, 03:07 PM   #4
Senior Member
 
Winnebago Owners Club
Join Date: Mar 2016
Location: CT
Posts: 254
Problem solved.

I feel a little stupid on this one. This issue was part of a bigger repair when my converter stopped working. Once I had everything installed and tested ok I was putting the panel and other stuff back together and I must have grounded out a wire or something. Everything flickered for a second but seemed to be okay until I found my 12V was out when on batteries only. I found today that I tripped one of the breakers in the front compartment where the MOBAC is located. I was looking in the battery compartment where the diagram says there is a relay or fuse but couldn't find one. Had I looked in this other compartment I would have seen there was another set of breakers and the main panel breaker was tripped. It was too dark outside for me to look further last night so I threw this thread up looking for help. Thanks to those who replied.
__________________
2010 Winnebago Vista 32K
2019 Jeep Wrangler Sahara toad
jpspaz is offline   Reply With Quote
Reply

Tags
batteries, need help



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Diagram on connecting coach & chassis batteries deaudlebug RV Systems & Appliances 2 03-27-2015 09:28 PM
Need help with connecting toad light cathjasp Newmar Owner's Forum 7 06-09-2014 09:31 AM
Need help connecting all these wires donnyjay Technology: Internet, TV, Satellite, Cell Phones, etc. 2 02-15-2012 10:15 AM
Connecting new auxiliary batteries BGoebel Class A Motorhome Discussions 6 06-01-2011 08:07 AM
Connecting Batteries newfiejeff RV Systems & Appliances 3 06-06-2006 07:18 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.