Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-28-2022, 08:51 PM   #1
Junior Member
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Feb 2019
Posts: 24
Onan miswired?

I have an Onan 4000 in my Winnie. Gen goes to plug where I plug in the shore power cord when traveling. A few years ago, it crapped out on a hot day and the repair place replaced the armature. Never seemed quite right since then. Last week I was moving the 30a plug from the generator (with generator and shore power off) and got a big spark. Wow. Discovered the neutral side of the gen output is connected to battery +12v.
This can’t be right! Ideas??
jorygun is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-28-2022, 09:32 PM   #2
Senior Member
 
Join Date: Dec 1969
Posts: 2,031
I would get an outlet tester: https://smile.amazon.com/Sperry-Inst...NsaWNrPXRydWU=

They come in handy on an RV. I would not think the problem is the generator.

Last year when I plugged into the 50 amp plug on the RV pedestal I wired, it did not work. Then it did. This year the 50 amd plug did not work but the 30 amp did.

Outlet tester said there was a problem.

Had to replace the 50 amp breaker on the pole. Then everything was good in the MH. However, the outlet tester said there was a problem in the 30 amp camping trailer. Turns out BIL had replaced the plug and not wired it correctly.

You problem could lots of things.
__________________
Kit & Rita (in memory)
37 foot ‘98 HolidayRambler Endeavor diesel pusher
followingsea is offline   Reply With Quote
Old 06-28-2022, 09:58 PM   #3
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 1,527
Do you have solar system ? Maybe disconnect that and test.. or disconnect each battery bank and test each time to figure out where it is coming from.. just what I would try..
Good luck and keep us posted
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Old 06-30-2022, 11:38 AM   #4
Junior Member
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Feb 2019
Posts: 24
Update on mis-wired gen

Took it to the RV shop today. The good news is I'm not an idiot: the tech saw the same thing I see. The bad news is the tech saw the same thing I see. He said he'd never seen anything like it. With everything off - no shore power, gen not running - the neutral side of the gen output is connected to a battery positive term. Not sure if it's house or coach batt. But that neutral wire is connected to a hot 12V.
Tech is going to contact Onan (but says their tech support isn't what it used to be). Maybe the controller is bad. Maybe someone bonded the battery + to neutral when it should have been battery -. Dunno.
__________________
—/Home wherever I am
jorygun is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Itasca Sunova Power Cord Receptacle Box miswired Astontibs Winnebago Industries Owner's Forum 2 06-22-2020 06:40 AM
A/C thermostat miswired zcaptain Entegra Owner's Forum 4 10-26-2017 07:56 AM
Retrofit Onan Carb with Commercial Onan Fuel Injection? DrLew iRV2.com General Discussion 10 01-23-2012 09:34 AM
Are Many Campground Power Outlets Really Miswired????? Logthumper Class A Motorhome Discussions 22 09-30-2006 06:34 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.