Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-30-2014, 04:25 PM   #1
Member
 
mikwallace's Avatar
 
Tiffin Owners Club
Join Date: Aug 2009
Posts: 71
P30 Chassis Dash Air Problems

Background: 1996 Winnebago Adventurer, P30 Chassis w/7.4L engine and SCS/ Frigette air conditioner. I've owned since 2009 and AC refrigerant has always had small leak. Before each trip I'd add one or two cans 134A refrigerant and bring pressures up to spec and AC worked fine for the trip. Usually took about a week before enough refrigerant leaked and AC wouldn't work. Also, plenum on firewall around Evaporator and heater core was cracked and pieces missing so temp fixed that with duct tape. Last week before a trip, I added refrigerant brought up to correct pressures, but it wouldn't blow cold air, only cool air. Never had that issue after charging. I decided to purchase plenum and find leak, repair and forever be happy. Cost of new plenum too expensive (more than 10% of the value of the whole rig), so I decided to remove and repair the plenum (repair went great and looks good). Determined refrigerant leak was at compressor, so bought new compressor, dryer, expansion block (THX), and AC flush. After removing compressor dryer and thx, I flushed both Evaporator and Condenser, put everything back together and pulled vacuum. Let vacuum sit appropriate amount of time to be sure leak was not present. Charged system. But still won't blow cold air??? Air in duct only down to 60 degrees.

So, AC experts please chime in!! What am I missing? Why won't it cool??
__________________
2013 Allegro Bus 43QGP
2017 Chevy 2500HD Toad
2016 Jeep Wrangler Toad
mikwallace is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-30-2014, 06:46 PM   #2
Junior Member
 
Join Date: Sep 2009
Posts: 14
check for vacuum leaks.

I had a 1991 P30 Winnie and the air was working great then one day..then the next barely cooled the air. Found that there was a vacuum leak. the vacuum leak will make the heater water control valve not shut off and put hot engine temp hot water into the heater core that heated the cooled air. so... I would check to make sure that the heater water control valve is closed (is the heater hoses going to the heater box hot?).. if it isn't closed then you either have a bad valve or vacuum leak and your air may be working just fine.
dali is offline   Reply With Quote
Old 07-03-2014, 09:42 AM   #3
Member
 
mikwallace's Avatar
 
Tiffin Owners Club
Join Date: Aug 2009
Posts: 71
Found vacuum switch problem but still no cold air

Thanks to your comment and a vacuum hose diagram, I found the switch on the temp control was not closing the water valve. I adjusted that so water valve closes, but still no cold air. I even bypassed the heater core completely, but still no cold air.

Every solution leads back to the expansion block. Although it's a new expansion block, I'm beginning to think it's the wrong size. Parts list from Winnebago calls for a 2 ton block, so I ordered one from Comfort Air that has the part number shown on Winnebago parts breakdown.

It'll be here next week and we'll see??!!
__________________
2013 Allegro Bus 43QGP
2017 Chevy 2500HD Toad
2016 Jeep Wrangler Toad
mikwallace is offline   Reply With Quote
Old 07-14-2014, 09:12 PM   #4
Member
 
mikwallace's Avatar
 
Tiffin Owners Club
Join Date: Aug 2009
Posts: 71
Update

Replaced expansion block and duct temp only gets down to 58 degrees, but air temp is 95. Have trip coming up and will see how it does going down the road. If this doesn't cool now the only thing left is the condenser.
__________________
2013 Allegro Bus 43QGP
2017 Chevy 2500HD Toad
2016 Jeep Wrangler Toad
mikwallace is offline   Reply With Quote
Old 08-03-2014, 12:55 PM   #5
Member
 
mikwallace's Avatar
 
Tiffin Owners Club
Join Date: Aug 2009
Posts: 71
Finally, all is working well. Took a beach trip two weekends ago and 38 degree air coming out vents. Copilot now complaint it's too cold!!

Then yesterday we traded for a 2006 Tiffin Allegro Bay!! Will pick it up next weekend.
__________________
2013 Allegro Bus 43QGP
2017 Chevy 2500HD Toad
2016 Jeep Wrangler Toad
mikwallace is offline   Reply With Quote
Reply

Tags
chassis, dash, dash air, p30



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newmar Dash Air for 2013+ And Older Coach's redbaron73 Newmar Owner's Forum 56 03-09-2018 09:45 PM
Erratic dash air blower bruceh Winnebago Industries Owner's Forum 9 07-10-2014 10:55 AM
Tradewinds Chassis Air conditioning mofa National RV Owner's Forum 6 06-03-2014 08:42 AM
Dash Air The baroness Monaco Owner's Forum 7 05-12-2014 09:05 PM
chassis air not cool hondaman Class A Motorhome Discussions 14 09-10-2013 09:34 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.