RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-23-2013, 03:34 PM   #1
Senior Member
 
Rorytug's Avatar
 
Join Date: May 2013
Posts: 194
Satellite picture loss Not signal loss.

My 2011 Itasca Sunova 33C was prewired for Satellite. The connections to the receiver consist of Component Cables and Stereo Audio cables as well as a 12 volt power transformer that must be plugged in to send the signal from the receiver to the two TV's.

Recently, the picture and audio fails at random times and I get a "No Signal" on my TV. My provider replaced the receiver but the problem still exists. I found that if I Unplug the power transformer mentioned above and plug it back in, the picture and audio come back for a short while before failing again. I have also found that the longer it is unplugged, the longer I have picture when plugged back in. It seems like a heat problem. Anyone out there have any idea if it might be the transformer or is there a switch box somewhere I need to find?
Rorytug is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-23-2013, 04:42 PM   #2
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 24,023
Might be the transformor,, Might be the modulator (The device it powers) IF you can cool it try.

Or try a better 12 volt "Brick". I have 'em that ... Well.. You don't want to knwo how big I've built 'em.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Reply

Tags
satellite



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.