Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-31-2011, 11:02 AM   #1
Member
 
Join Date: Jun 2009
Posts: 84
Xantrax Heart Interface Control

Hi--

I have a Xantrax Heart Interface Control panel on my 2003 Winnebago Journey DL. I plugged it in today to my 15 amp outlet with appropriate adapters and it did not seem to be charging. I checked and it had tripped off the breaker I plugged it into. Now the panel is blank and has no lights on it. Not sure what happened or how to fix. I checked all the breakers in the rv and all seems fine. Everything works on genny power. Any idea? I appreciate your help.

Steve
stardalo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-04-2011, 07:52 AM   #2
Registered User
 
Winnebago Owners Club
Join Date: Oct 2009
Posts: 848
We had problems with ours. Called the factory.. I was told to (carefully) take the Panel out unplug The wire It was like a phone jack plugin, Leave it unpluged for 3 minutes and plug it back in, Which I did and Presto; it worked fine;; The tech, said that it will reset its self. Which it must have,,
bachler is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blue Ox TruCenter Steering Control Joe-K Gear and Product Discussions 14 03-31-2019 03:29 PM
Resetting the Service light 4x4crazy Cummins Engines 6 03-01-2011 08:26 PM
Cruise Control On A Discovery Volunteer Fleetwood Owner's Forum 5 01-03-2011 01:53 PM
Heart Interface Echo Charger Question Eusefull Alpine Coach Owner's Forum 13 03-21-2007 06:50 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.