Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-27-2021, 04:29 PM   #1
Junior Member
 
Join Date: Oct 2021
Posts: 5
2006 Newmar Essex, no brake lights or rear turning signal

Can anyone tell me where the fuses are on a 2006 Newmar Essex 4502
Spartan K2 500 chassis. I have read everyone’s post based on where theirs
are. I have contacted Newmar and the call it “free wiring” which means where
ever the assembly person feels like mounting it. I have checked everywhere, under drivers seat compartment, in genset area, behind aqua hot, 1/2 compartment on passenger side, in front and behind passenger wheels, in rear compartment busman, fuses are good on top of batteries . I have crawled around under, through, taken radio and TVs out. Can anyone help me find the rear brake&turning signal fuses? Newmar can’t help and Spartan told me good luck
Tuuri1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-27-2021, 11:32 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,883
Welcome to iRV2 and the Newmar family.

Free wiring ; now that's a little unusual ; I do know that sections of the harness are laid out on the frame, with length , for the coach builder to mount and from my experience with Dutch Star ( 99/03 ) built on Spartan chassis , Newmar was consistent with the placement of the chassis fuse boxes in the compartment behind the passenger side duals .
You say you've checked Busman boxes , did the boxes you found look like these .
Yellow box , in photo .

Spartan is usually pretty good with their wiring info, did they mention an approx area where the fuses could be found , dash , rear ?
I have Spartan schematics for chassis up to 02, and the layout gives a good approximation .
Attached Images
 
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 10-28-2021, 12:04 AM   #3
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,883
I was involved with another member with no brake lights in a Fleetwood coach on a Spartan chassis .
When he contacted Spartan they sent him wiring schematics; linked to his serial number ; and he shared them with me .

His post.

http://www.irv2.com/forums/f258/flee...ts-556633.html

The pdf of wiring info is too big to post here in the forums .
But if you check out the picture he posted of his chassis fuse box and yours is the same , I can send you the schematics , or maybe Spartan will send you a copy for the chassis they supplied to Newmar.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 10-28-2021, 09:48 AM   #4
Member
 
STRich's Avatar
 
Join Date: Nov 2020
Posts: 45
On my unit, in the power reel compartment there is a plastic panel held on with Velcro. There are a bunch on 12 volt fuses back in there for the step, the radio and a few other items. I don't have a clear picture to see if it also covered the brake lights.

The panel is all the way in the back and hides the emergency start solenoid and other bits.
__________________
2008 Newmar Mountain Aire 4529
Spartan K2 Chassis
STRich is offline   Reply With Quote
Old 10-31-2021, 08:13 PM   #5
Junior Member
 
Join Date: Oct 2021
Posts: 5
Skip426

The Bussman boxes look a little different, they are labeled well. I did get the wiring schematic from Spartan but they left it up to the manufacturer were to mount it.

STRich

I have the same Velcro panel behind the 50amp cord. I didn't see any 15amp fuses that reference turn/brake lights.

It's crazy to say I know the bulbs aren't blown because I can turn the signal and brake lights through my tow vehicle.

I appreciate all the help I can get, thank you so much
Tuuri1 is offline   Reply With Quote
Old 10-31-2021, 08:59 PM   #6
Member
 
JMWheeler's Avatar
 
Join Date: Feb 2018
Posts: 39
We had that on our Ventana, but it is on a Freightliner chassis. It was the subject of a recall due a faulty module. Had it replaced before it failed and it failed later. They replaced it and it has since been recalled again. We haven’t taken it back it for the second recall.
__________________
Johnny Wheeler
2018 Ventana 3407
2021 Ford F-150 4x4
JMWheeler is offline   Reply With Quote
Old 10-31-2021, 09:55 PM   #7
Member
 
STRich's Avatar
 
Join Date: Nov 2020
Posts: 45
Hmmm, so both of those lights have to go through the turn signal switch. Can you see if you have power in and out of that? If you turn the key on, will the cameras follow the switch?

Just spitballing a little, but I had an old Dodge that I had a similar issue and the switch as the culprit.
__________________
2008 Newmar Mountain Aire 4529
Spartan K2 Chassis
STRich is offline   Reply With Quote
Old 10-31-2021, 10:46 PM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,883
Quote:
Originally Posted by STRich View Post
Hmmm, so both of those lights have to go through the turn signal switch. Can you see if you have power in and out of that? If you turn the key on, will the cameras follow the switch?

Just spitballing a little, but I had an old Dodge that I had a similar issue and the switch as the culprit.
Yes you have to know there is output to the rear from the signal switch , then Spartan has relays in the rear that need to be powered ( fuse ) and activated from the signal switch and fuses after the relays, for both the coach and trailer lights . After seeing the Spartan wiring schematic for the 2006 Fleetwood chassis , I can say It's unnecessarily complex .
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 11-02-2021, 06:25 PM   #9
Junior Member
 
Join Date: Sep 2021
Posts: 4
Have you checked at the bulb socket ? I have a 2005 Kountry Star and every so often I have to clean and tighten the socket that the bulb goes in. Check for power using a Volt Meter or a Test Light.
Wmitch2 is offline   Reply With Quote
Old 11-02-2021, 10:12 PM   #10
Senior Member
 
BrokeDown's Avatar
 
Join Date: Mar 2016
Location: Fort Myers, FL
Posts: 531
On my 08 K2 Spartan, there are 2 boxes mounted on the passenger side frame rail in the compartment next to the tanks (black, gray, fresh). The boxes are roughly 5" x 6" and have a quarter-turn lock on them. They are next to the right-side slide controllers. The boxes have fuses and relays for the taillights, brake lights, and turn signals.

-B
__________________
2008 MADP 4523 w/Hydralift MC Lift - 2016 Jeep Rubicon HR Unlimited - 2012 Harley FLTRU
2022 Momentum 351MS-R (ordered) - 2022 F450 Platinum (ordered)
Fulltime RVing since 4/16/16 - FMCA F477382
BrokeDown is offline   Reply With Quote
Old 11-15-2021, 06:21 AM   #11
ala
Junior Member
 
Join Date: Oct 2018
Posts: 1
Hi I am having same problem with locating that chassis fuse box . Have no rear signals or brake lites . 2006 Essex. Stuck on the road . Thanks Al
ala is offline   Reply With Quote
Old 11-15-2021, 11:19 AM   #12
Senior Member
 
Join Date: Jan 2011
Posts: 518
I had the same issue on my 2006 Mountain Aire, I had to get a new flasher from Spartan direct.
They use a special flasher so know parts house had one!
__________________
2006 Mountain Aire, Jeep LJ, 900 watts of solar, boondocking life away! Volunteer Fire Fighter!
hes4all is offline   Reply With Quote
Old 11-16-2021, 01:50 PM   #13
Junior Member
 
Join Date: Oct 2021
Posts: 5
Quote:
Originally Posted by Wmitch2 View Post
Have you checked at the bulb socket ? I have a 2005 Kountry Star and every so often I have to clean and tighten the socket that the bulb goes in. Check for power using a Volt Meter or a Test Light.

Bulbs are good, can actuate blinkers and brake light from tow vehicle on to coach
Tuuri1 is offline   Reply With Quote
Old 11-16-2021, 01:51 PM   #14
Junior Member
 
Join Date: Oct 2021
Posts: 5
Quote:
Originally Posted by hes4all View Post
I had the same issue on my 2006 Mountain Aire, I had to get a new flasher from Spartan direct.
They use a special flasher so know parts house had one!
Front and side flashers are good.
Tuuri1 is offline   Reply With Quote
Reply

Tags
brake, brake lights, essex, light, lights, newmar, rear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear lights not working, brake lights/ turn signals(rear only) and all other lights o Kloussen Monaco Owner's Forum 3 03-24-2021 10:50 AM
2006 Essex :: 2006 Newmar Essex WA-MEX iRV2 Owners Registry 0 08-13-2020 11:06 AM
1997 HR Vacationer Ford F53 Brake and turning signal lights troubleshooting issue jpaduchak Ford Motorhome Chassis Forum 3 07-10-2018 02:52 PM
No signal lights, headlights, docking lights, brake lights dvleemin Class A Motorhome Discussions 10 08-06-2017 06:01 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.