RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-11-2014, 08:15 PM   #1
Senior Member
 
Join Date: Aug 2010
Location: MI & AZ
Posts: 233
2014 Ventana - water pump switches stopped working. Workaround

We got ready to leave for the southwest yesterday. We had not used the water pump for a while since hooked to water. None of the four water pump switches would work. No green LEDS on the switches would light either. I found the fuse in the electric cabinet on the bathroom. Fuse good and monitor panel that is also on the fuse is working. I called Newmar Tech and explain the problem. He agrees to send out a replacement 'relay' and tells me where it is down beside the water pump.
WORKAROUND UNTIL THE RELAY BOARD ARRIVES.
I found the relay which is a small PC board about 1.5 in wide and maybe 4 inches tall. It has four terminals and spade clips with wires and two LEDS, a green and yellow. Neither LED lights when a pump switch is pressed. The terminals are labeled on the card as :
1/ 12 Volts with a second wire on this terminal going to the pump pressure switch. This pin and thus the pressure switch had 12 v on it.
2/ Switches - this pin and wire apparently comes from the four switches probably wired in series but I have no wiring diagram.
3/ Load - this pin had a single black wire that goes to the pump motor negative side.
4/ Ground - this pin had two wires both at ground potential.

I theorize that when one of the four momentary switchs is pressed to turn on the water pump a solid state relay picks and holds that transfers the ground to the load pin thus starting the pump if the pressure switch shows that water is needed. This was not happening and no LEDS light either on the PC board or the switch boards on the wall.

I just pulled the black wire off the pin labeled LOAD and attached it to a jumper I ran to ground and the pump works as it would with a switch on letting the pressure switch turn it on when water is run.

A simpler workaround would be to just run a very short jumper from the LOAD terminal to the GROUND terminal.
NOTE: Since the control is on the ground side the fuse for the pump in both workaround methods above is still in place protecting the circuit.

Ted
__________________

__________________
Ted & Ruth Ann Hindes - NKK AZ State Directors
2014 Newmar Ventana 4377, 1400 Watts of Solar, Air Force 1 Brake, 2014 Grand Cherokee Overland
tednruthy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-11-2014, 11:19 PM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,209
A ground is common to all switch's some place.
Wiring water pump, found in links below.
Many controls in a Newmar.
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-12-2014, 07:10 AM   #3
Senior Member
 
andyh's Avatar
 
Newmar Owners Club
Join Date: Jul 2007
Location: Troy, MI
Posts: 629
The pump switches are wired parallel, so any one of them with a momentary closing (push) can switch the state of the controller. You did the right thing for a temporary fix.
__________________
Andy

2015 DSDP 4369 with HWH Active Air, 2014 Jeep Grand Cherokee, Roadmaster tow bar, SMI AirForce One, Silverleaf VMSPc
andyh is offline   Reply With Quote
Old 10-12-2014, 02:37 PM   #4
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 15,350
Ted.....After reading your post, we went out to the motor home today to clean it for an upcoming trip. My wife turned on the water pump...no water. All fuses are good.

I checked the latching controller in the water bay and I think's it's dead. The model is a C-Storm WPC145. I have power into the controller and when I connect an ohm meter and hit one of the water pump switches, I'm getting the ground that triggers the controller. It looks like it died.

I looked for one on the internet and it looks like Newmar may have found the cheapest one available. These things shouldn't die that easily. I couldn't find anyone selling one, just the company website that makes it and they don't even list it in their line of products.

On my Monaco, it had an Intellitec controller, looks the same, is the same 10 amp size and uses the same four connectors. I'm ordering one two day air and will look tomorrow for one locally when some of the RV parts stores open. I will carry a spare after this.

Ebay has two choices for the Intellitec 00-00145-100. One is sold by AnyRVparts.com. I went to their website and it's a few dollars cheaper.
__________________
Don & Mary
2019 Newmar Dutch Star 4018
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Old 10-12-2014, 05:34 PM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,209
The Intellitec one that I show has been in my coach for over ten years and never had a problem at four locations.
If you click on the picture in link provide it than will give you some place to order a new one.
Now that being said in the ten years I still have not found its location if I did have to replace it, believe me I have looked.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-12-2014, 05:45 PM   #6
Senior Member
 
Mr_D's Avatar
 
Country Coach Owners Club
Winnebago Owners Club
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 36,781
Quote:
Originally Posted by 007";2266835]The Intellitec one that I show has been in my coach for over ten years and never had a problem at four locations.
If you click on the picture in [B][URL="https://www.google.com/search?q=RV+intellitec+slide+controls&hl=en&prmd=i mvns&source=lnms&tbm=isch&ei=jU_NT4-xLPD16AG0q70v&sa=X&oi=mode_link&ct=mode&cd=2&sqi=2 &ved=0CGEQ_AUoAQ&biw=1236&bih=642&gws_rd=ssl
link provide[/URL][/B] it than will give you some place to order a new one.
Now that being said in the ten years I still have not found its location if I did have to replace it, believe me I have looked.
Yep, when we ordered our DSDP the Intelletic controller was only standard on the MADP so we opted for it. So far it's been working just fine for 12 years.
On ours it's behind the wet bay cover panel, right next to the water pump.
__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 Jeep JKU Dragon Edition
Mr_D is offline   Reply With Quote
Old 10-12-2014, 06:45 PM   #7
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 15,350
I'm going to try and get Newmar to send me the C-Storm under warranty and keep it as a spare.
__________________
Don & Mary
2019 Newmar Dutch Star 4018
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Old 10-12-2014, 07:02 PM   #8
Senior Member
 
FLSteve's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2011
Location: Fort Myers, FL
Posts: 1,270
Mine went out a month ago as well and I ordered one directly from C-Storm Electronics, LLC. They were very helpful. Ask for Brandon (630) 406-1353. I think it was about $29 plus shipping. I did the same work around as tednruthy did in the interim.

Steve
Attached Thumbnails
Click image for larger version

Name:	Water Pump Switch 1.jpg
Views:	304
Size:	132.0 KB
ID:	76416   Click image for larger version

Name:	Water Pump Switch 2.jpg
Views:	1024
Size:	298.7 KB
ID:	76417  

__________________
Steve & Lisa
2019 Dutch Star 4018
2018 JL Rubicon & 2019 Cherokee Trailhawk Elite
FLSteve is offline   Reply With Quote
Old 10-12-2014, 07:26 PM   #9
Senior Member
 
Lloydu's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2011
Location: Portland, Oregon
Posts: 549
Quote:
Originally Posted by FLSteve View Post
Mine went out a month ago as well and I ordered one directly from C-Storm Electronics, LLC. They were very helpful. Ask for Brandon (630) 406-1353. I think it was about $29 plus shipping. I did the same work around as tednruthy did in the interim.

Steve
Hi Steve,
I believe I have a similar problem. My green light flicks on and off no matter if I try to turn the switch off or not. I can hear a relay clicking like crazy behind the water compartment plate by the water pump. Thoughts?
Lorraine and I really appreciate all your help in organizing Hoot II and hope we can work it into our travel plans to attend Hoots III.
Aloha!
Lloydu is offline   Reply With Quote
Old 10-12-2014, 08:00 PM   #10
Senior Member
 
FLSteve's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2011
Location: Fort Myers, FL
Posts: 1,270
Lloydu ... that does not sound like the same issue. Can you tell if the water pump is trying to run or is running? Sounds like it might have something to do with the pressure sensor that turns the pump on/off as you use water.?

Steve
__________________
Steve & Lisa
2019 Dutch Star 4018
2018 JL Rubicon & 2019 Cherokee Trailhawk Elite
FLSteve is offline   Reply With Quote
Old 10-12-2014, 08:03 PM   #11
Senior Member
 
Lloydu's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2011
Location: Portland, Oregon
Posts: 549
Steve,
The water pump does and wants to run. Where is this sensor and how of I access it?
Lloydu is offline   Reply With Quote
Old 10-12-2014, 08:17 PM   #12
Senior Member
 
FLSteve's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2011
Location: Fort Myers, FL
Posts: 1,270
Lloydu ... I am not 100% sure but I think it might be on the discharge side of the pump and a part of the pump itself. Maybe someone that knows the answer will weight in.

Steve
__________________
Steve & Lisa
2019 Dutch Star 4018
2018 JL Rubicon & 2019 Cherokee Trailhawk Elite
FLSteve is offline   Reply With Quote
Old 10-13-2014, 03:51 AM   #13
Senior Member
 
FLSteve's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2011
Location: Fort Myers, FL
Posts: 1,270
Lloydu ... just thought of one more thing. I remember Deek mentioning that he had some kind of "air lock" in his system when he was leaving Hoots II. Wonder if it might be something like that?

Steve
__________________
Steve & Lisa
2019 Dutch Star 4018
2018 JL Rubicon & 2019 Cherokee Trailhawk Elite
FLSteve is offline   Reply With Quote
Old 10-13-2014, 12:04 PM   #14
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 15,350
I'm amazed at Newmar's willingness to assist the owner over the phone. I called early this morning regarding the controller. I told them I had checked the system and determined the controller had failed. No questions, no hesitation......your part is on the way. I paid to upgrade to 2nd day air and it was shipped this morning.

Most manufacturers demand you drag the coach to a shop for diagnosis. What a pain on a simple problem. The parts guy says they don't always just ship parts, but in certain situations they do. I'm guessing Newmar saved $80.00 - $100 in warranty charges from the dealer. Smart business.
__________________

__________________
Don & Mary
2019 Newmar Dutch Star 4018
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Reply

Tags
vent, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump Check Valve? coachmanrvr Entegra Owner's Forum 13 10-24-2014 06:17 PM
2015 F53 Windshield Water Pump Not Working snoodledog Ford Motorhome Chassis Forum 11 10-05-2014 12:03 AM
Location of water pump in 02 Dutch Star DP bnsonger47 Newmar Owner's Forum 6 05-28-2014 01:45 PM
A/C condensation water. Where does it drain to on a 2014 Ventana? tednruthy Newmar Owner's Forum 5 05-06-2014 07:07 PM
Water Pump Relay Location Sohapi Monaco Owner's Forum 15 03-08-2014 11:17 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×