RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-24-2020, 02:28 PM   #1
Member
 
ascdds's Avatar
 
Newmar Owners Club
Join Date: Oct 2016
Posts: 72
A/C fan keeps running

The fan of my Dometic rear rooftop A/C unit will not stop running when on A/C mode. It only runs when it’s supposed to when it’s in Heat Pump mode. The fan is set to ”Auto” like it always has been and like the front unit is. Front unit works normally but the rear fan keeps blowing even when the temp gets below the set temp and the A/C stops cooling. Any ideas?
__________________

ascdds is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-24-2020, 05:08 PM   #2
Senior Member
 
Switt's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Feb 2015
Location: Kingsport,Tennessee
Posts: 179
Turn off battery disconnect for about one minute. Should reset thermostat solved my problem.
__________________

__________________
Sam&Tobe
2019 Ventana 4037
2014 CRV
Switt is offline   Reply With Quote
Old 01-24-2020, 05:44 PM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar
 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 40,565
I would first do the factory reset on the thermostat!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 01-24-2020, 09:00 PM   #4
Member
 
Join Date: Jan 2019
Posts: 49
I had a similar problem with one of mine and it turned out to be a thermistor. After running fine most of the day , lt would start acting up. the fan would keep running and the compressor would shut off. The fan would keep running and then shut off for a few seconds and then start again and the compressor would then come back on. After reaching temp then the comp. would shut off and the fan would keep running.

The HP worked just fine during the night .
__________________
Doug & Melba and sidekick Sugar
2014 GMC dmax, crew, dually
2015 DRV Tradition
00 Buckshot is offline   Reply With Quote
Old 01-25-2020, 10:14 AM   #5
Member
 
ascdds's Avatar
 
Newmar Owners Club
Join Date: Oct 2016
Posts: 72
I pulled the fuse for the thermostat, left it out for a minute then reinserted it and that reset the thermostat and solved the problem. Thanks for the help.
__________________
Scott and Regina Cross
2017 Newmar Ventana LE 4037
2016 Jeep Wrangler Sport
ascdds is offline   Reply With Quote
Reply

Tags
fan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan-tastic fan won't stop running juliegee333 5th Wheel Discussion 6 06-15-2013 07:27 AM
Furnace keeps running and running and... marcdohc RV Systems & Appliances 2 10-10-2012 09:58 PM
Heater Fan Keeps Running bruceh RV Systems & Appliances 22 12-02-2009 04:19 AM
Water Pump keeps running Between Trips RV Systems & Appliances 4 04-25-2005 03:38 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×