Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-27-2022, 02:02 PM   #1
Junior Member
 
Join Date: Feb 2014
Posts: 17
AC problem

The front Dometic AC unit has recently stopped working properly and I am wondering whether to try to get it repaired or just have it replaced. This is one of the original units on my 2004 Dutch Star.
The unit will sound like it is starting up and the fan will come on but there is no cooling. Same thing on the heat pump mode. No heating.
I know that it is pulling power because the generator kicks up to high rpm when the unit starts.
Any and all opinions and ideas are requested and appreciated!
__________________
2004 Dutch Star 3812
Freightliner, Cat C-7 330 hp
Newmar Tom is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-27-2022, 02:04 PM   #2
Community Administrator
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 14,995
It could be as simple as replacing the start capacitor on the compressor. If you can repair it I would as replacement units are hard to come by now.
__________________
2017 Phaeton 40IH XSH Maroon Coral - Power Glide Chassis with IFS
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'16 Jeep JKU Wrangler Sahara or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 06-27-2022, 02:14 PM   #3
Senior Member
 
Join Date: Jul 2018
Posts: 3,964
If you're lucky the problem is a failed compressor start capacitor. Likely an under $50 part(s). In most unit these are fairly easy to replace but I've no direct experience with Dometic air conditioners of your vintage.

It replacing the cap(s) does not fix the problem you'll probably need a replacement A/C.
__________________
2005 Four Winds Majestic 23A
“To the world you may be one person; but to one person you may be the world.” - Dr Suess
Solo_RV_Guy is offline   Reply With Quote
Old 06-27-2022, 02:23 PM   #4
Senior Member
 
mackpeteno's Avatar
 
Country Coach Owners Club
Texas Boomers Club
Fleetwood Owners Club
Join Date: Apr 2011
Location: Snyder,Tx.
Posts: 143
I had the same problem last year.Pulled the cover to look at it .Just a loose connection.Cleaned and re crimped.Works fine now.
mackpeteno is offline   Reply With Quote
Old 06-27-2022, 04:52 PM   #5
Senior Member
 
Dutchstar411's Avatar


 
Newmar Owners Club
Join Date: Dec 2015
Location: Wellington, Florida
Posts: 1,358
Quote:
Originally Posted by Lt Dan View Post
It could be as simple as replacing the start capacitor on the compressor. If you can repair it I would as replacement units are hard to come by now.
Ditto x2
__________________
Ted & Nancy with our fur kids Mr. Vincent & Miss Daisy
2015 Newmar Dutch Star 4018
2002 Newmar Dutch Star 3852
2020 Jeep Wrangler Rubicon
Dutchstar411 is offline   Reply With Quote
Old 06-27-2022, 05:41 PM   #6
Senior Member
 
Country Road's Avatar
 
Join Date: May 2021
Location: Brenham, Texas
Posts: 1,073
Quote:
Originally Posted by Newmar Tom View Post
The front Dometic AC unit has recently stopped working properly and I am wondering whether to try to get it repaired or just have it replaced. This is one of the original units on my 2004 Dutch Star.
The unit will sound like it is starting up and the fan will come on but there is no cooling. Same thing on the heat pump mode. No heating.
I know that it is pulling power because the generator kicks up to high rpm when the unit starts.
Any and all opinions and ideas are requested and appreciated!
You’ve gotten good info. Fix it if you can, but I will say that if you replace it, you will see a day and night difference in cooling power. New ac technology is amazing compared to almost 20 years ago.
__________________
Eddie and Jomaye, Retired
2018 Newmar Ventana 4369
2021 Jeep 4 dr Wrangler
Country Road is offline   Reply With Quote
Old 06-28-2022, 11:23 AM   #7
Junior Member
 
Join Date: Feb 2014
Posts: 17
Thanks!

Many thanks to all! I will replace the start capacitor and hope for the best!
__________________
2004 Dutch Star 3812
Freightliner, Cat C-7 330 hp
Newmar Tom is offline   Reply With Quote
Reply

Tags
problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RV House Lights Problem, Battery relay problem? c2sbear Class A Motorhome Discussions 7 10-10-2016 10:33 AM
Brake problem repaired,new problem with tank sensors. steve4539 Winnebago Industries Owner's Forum 1 11-02-2015 10:41 AM
Problem Or No Problem TeresaOwen1 Class A Motorhome Discussions 2 08-02-2014 06:41 PM
Sat Dome Problem or Electrical Problem?? fansill Technology: Internet, TV, Satellite, Cell Phones, etc. 5 04-25-2011 11:34 PM
Problem diagnosing Allison 1000 problem classic60 Allison Transmission Forum 4 11-16-2010 10:32 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.