RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-19-2017, 04:29 PM   #1
Member
 
Heli_fixer's Avatar
 
Join Date: Feb 2017
Location: Hamilton, Ontario
Posts: 41
Cockpit vent/air conditioning blower quit working

Hi All,
In my 2009 Ventana on my last trip today, my vent blower just sudden stopped working while driving home. I checked fuses in the front left side and right aft side just ahead of the batteries. Swapped a couple of relays, all with no help. I pulled the panel forward where the switch is located and checked for power at the connection to the switch. No power. I ran 12 volts to the red wire and the fan runs on low speed. Any thoughts?
Attached Thumbnails
Click image for larger version

Name:	IMG_20170619_153628.jpg
Views:	37
Size:	297.3 KB
ID:	165755   Click image for larger version

Name:	IMG_20170619_153623.jpg
Views:	36
Size:	274.1 KB
ID:	165756  

__________________

Heli_fixer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-19-2017, 04:38 PM   #2
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: Foley AL
Posts: 7,124
Quote:
Originally Posted by Heli_fixer View Post
Hi All,
In my 2009 Ventana on my last trip today, my vent blower just sudden stopped working while driving home. I checked fuses in the front left side and right aft side just ahead of the batteries. Swapped a couple of relays, all with no help. I pulled the panel forward where the switch is located and checked for power at the connection to the switch. No power. I ran 12 volts to the red wire and the fan runs on low speed. Any thoughts?

There is usually a resistor pack that is installed in the housing surrounding the fan. It burns out eventually. Typically available at car parts stores.

Have a look under the dash ... it's installed such that the resistors are in the airstream inside housing to cool the resistors.

Something like this:
__________________

__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Old 06-19-2017, 06:01 PM   #3
Member
 
Heli_fixer's Avatar
 
Join Date: Feb 2017
Location: Hamilton, Ontario
Posts: 41
Good thought. I'll have a look. T
Heli_fixer is offline   Reply With Quote
Old 06-20-2017, 12:22 PM   #4
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,118
All EVAN's info in QT's # 3 , parts, diagrams and drawings for trouble shooting.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 06-22-2017, 08:30 PM   #5
Member
 
Heli_fixer's Avatar
 
Join Date: Feb 2017
Location: Hamilton, Ontario
Posts: 41
Thanks again 007. Forgot about those QT's. Most helpful.
__________________
2009 Newmar Ventana 3936
2013 Ford Focus Titanium
Heli_fixer is offline   Reply With Quote
Reply

Tags
vent, air conditioning



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vansco output fault - Blower 1, Blower 2, Blower 3 c_oneil Alpine Coach Owner's Forum 2 03-24-2017 08:35 AM
A/C blower motor quit on 1997 Newmar London-Aire jdash Newmar Owner's Forum 3 08-01-2012 06:14 PM
Dash Air Conditioning Blower Infinity 2 Thor Industries Owner's Forum 6 07-13-2012 07:27 PM
cockpit fans not working bobsshop Class A Motorhome Discussions 4 10-09-2011 01:29 PM
Dash air blower quit working sharring Newmar Owner's Forum 2 08-26-2011 08:27 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×