Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-17-2020, 07:16 PM   #1
Member
 
Johngflyer's Avatar
 
Join Date: Aug 2015
Location: Crescent City, FL
Posts: 60
Cruise control will not stay on

Cruise control on our 2016 Dutchstar will not stay on. The Freightliner chassis was built in 2015.
Turn cruise on and after 5-15 seconds, goes off.
This happens if engaged or not.
The real mysterious part is when the cruise control goes off, the back up camera screen goes blank for a second but comes right back on.
The above happens even when parked with the engine running running. If engine is turn off but key is in on position and the cruise is turned on, it stays on forever until key is turned off.
Any suggestions as to the cause will be greatly appreciated. Thanks.
__________________
2016 Dutchstar 3736.
Towing trailer hauling a SMALL plane and Vette
Johngflyer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-18-2020, 07:36 AM   #2
Senior Member
 
Join Date: May 2014
Location: SW Florida in winter NW Michigan in summer
Posts: 131
I had a 2015 DS 4018 that had similar issue. Freightliner had a recall for a brake pedal spring. If you pull brake pedal up with your foot the cruise would work. Once Freightliner replaced spring it went away. I didn’t have issue with camera. Good Luck
Gheidbrink is offline   Reply With Quote
Old 11-18-2020, 09:48 AM   #3
Junior Member
 
Join Date: Nov 2020
Posts: 2
You got a tail lite bad somewhere when you hit a bump in the road your bulb will flicker turning you cruise off I had that happen on my unit I have a special set up on my pickup I tow 4 wheels down with a special two bar into the receiver check all your tail lite bulbs
Biged73 is offline   Reply With Quote
Old 11-18-2020, 02:22 PM   #4
Senior Member
 
Join Date: Sep 2010
Posts: 4,123
Had the issue on Essex and it was a loss connection down in the outside under drivers seat smart wheel wiring. Disconnected plug in on Black box and check to make sure not loss and problem gone.
Newmar Man
__________________
Tom/Teri 16031 NKK 117995 FMCA
18 London Aire 4531 Spartan K-3 605
97-04 LA 04-18 Essex 2018 London Aire
tom chelbana is offline   Reply With Quote
Reply

Tags
cruise control



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise King cruise control Old Car Nut Country Coach Owners Forum 2 10-24-2019 12:25 AM
Eco Cruise Cruise Control LSepulveda iRV2.com General Discussion 6 03-30-2016 07:52 AM
Cruise Control Downshifts Into 5th; Won't Stay In 6th Gearhead383 Monaco Owner's Forum 18 06-25-2013 06:09 AM
Cruise Control/Wiper Control/Bright Light Control cnjcampione Winnebago Industries Owner's Forum 2 05-21-2011 08:38 PM
Cruise Cruise Not Maintaining Speed ep35rja Winnebago Industries Owner's Forum 9 05-24-2006 11:58 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.