Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-01-2014, 10:52 AM   #1
Senior Member
 
RangerRick's Avatar
 
Join Date: Nov 2011
Posts: 167
Dash Gauge Problem

I recently purchased a 2005 Newmar Kountry Star on a Spartan chassis and am having a problem with the dash gauges. A couple of times when I turned the ignition on the gauges did not work nor did any of the warning lights. I cycled the key a couple of times and everything then worked. The gauges and warning lights are out now and will not come on.
I have done some testing and the ignition switch tests ok. In the chassis fuse panel all fuses and relays test good but there are two fuses not getting power. They are labeled "Guauge" and "Inst". Looking at the back od the panel they are interconnected so no doubt have a common feed. If I use a jumper wire to supply power to the fuse everything works so there is a problem either in the fuse panel itself or in the feed to the panel.
Does anyone have a wiring schematic of the chassis including the fuse panel? It would save me a lot of time in searching for this problem, or has anyone had the problem?
RangerRick
RangerRick is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-01-2014, 01:41 PM   #2
Senior Member
 
dennis45's Avatar
 
Join Date: Jun 2012
Location: AB
Posts: 7,587
Give Spartan a call with your VIN number and they will email all electrical drawings. They will also be very helpful with troubleshooting.
__________________
2019 Unity LTV CB, pushed by a 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake
dennis45 is offline   Reply With Quote
Old 02-01-2014, 03:27 PM   #3
Moderator Emeritus
 
"007"'s Avatar
 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,786
Welcome to the forum and irv2.
In the Spartan Chassis forum you will find wiring diagrams in a sticky top of forum that may help you.
You may want to check the grounds also for loose connections while your at it plus your battery connections on fuse panel.
In my signature below are three links that will steer you to more wiring and battery info for your Newmar.
Here is a Brochure and Owners Guide for you.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 02-02-2014, 11:53 AM   #4
Senior Member
 
RangerRick's Avatar
 
Join Date: Nov 2011
Posts: 167
Thanks everyone for the input. I found the wiring diagrams and they led me directly to the problem, a fuse in the battery compartment.
RangerRick
RangerRick is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Dutchstar Dash Heat problem Usa1chris Newmar Owner's Forum 10 11-06-2013 10:55 AM
Dash Removal on '94 Flair hardball28 Class A Motorhome Discussions 2 07-09-2013 06:32 AM
Dash / Instrument Cluster Removal on '94 Flair hardball28 Class A Motorhome Discussions 0 07-08-2013 06:47 PM
Class A Diesel pusher Dash AC -working or not flht95 Class A Motorhome Discussions 4 07-07-2013 05:50 PM
Alpine 2004: Dash Warning Buzzer quit working, can't find it! Mike & Mike Alpine Coach Owner's Forum 6 06-23-2013 10:00 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.