Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-24-2021, 08:17 PM   #1
Author, Speaker, Advisor
 
davidcbaker's Avatar


 
Newmar Owners Club
Freightliner Owners Club
RV Trip Wizard
Join Date: Jun 2021
Location: Nashville, TN, USA
Posts: 85
Dash Not Working

'21 New Aire 3545. Apparently I'm part of the inoperative dash recall. About a month ago it turned off. I shut off the vehilce and restarted it and no problems since. 6k miles.

Just started it now and it remained blank. Let it run, tried a half dozen times, etc. No joy.

Any ideas on getting it working before I can get it to the shop? I guess it SEEMS like it's related to the recall, but I've often gotten in trouble making assumptions like that. Maybe it's something else.

Voltage is 13.6. It's never not been plugged in to shore power or actually running.

I'd appreciate your ideas.
__________________
____________
David C. Baker (Nashville): author | speaker | advisor | airplanes | helicopters | motorcycles | photography | woodworking | rving
davidcbaker is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-25-2021, 05:45 AM   #2
Senior Member
 
Join Date: Nov 2020
Posts: 239
Its probably the Viper module. You can test, open the dash, unplug the ethernet cable for 15 minutes, plug it back in and see if it works. Otherwise I drove blind for over 550 miles to get it fixed as the Orlando FL dealer is the absolute worst. Gaffney took care of it immediately
__________________
2021 Newmar Ventana 4369 Freightliner Chassis
2020 Chevy Blazer Toad
Winger2 is offline   Reply With Quote
Old 11-25-2021, 10:24 AM   #3
Author, Speaker, Advisor
 
davidcbaker's Avatar


 
Newmar Owners Club
Freightliner Owners Club
RV Trip Wizard
Join Date: Jun 2021
Location: Nashville, TN, USA
Posts: 85
Quote:
Originally Posted by Winger2 View Post
Its probably the Viper module. You can test, open the dash, unplug the ethernet cable for 15 minutes, plug it back in and see if it works. Otherwise I drove blind for over 550 miles to get it fixed as the Orlando FL dealer is the absolute worst. Gaffney took care of it immediately
Do you happen to recall the procedure for removing the dash? Thanks.
__________________
____________
David C. Baker (Nashville): author | speaker | advisor | airplanes | helicopters | motorcycles | photography | woodworking | rving
davidcbaker is offline   Reply With Quote
Old 11-25-2021, 10:36 AM   #4
Senior Member
 
Join Date: Nov 2020
Posts: 239
Quote:
Originally Posted by davidcbaker View Post
Do you happen to recall the procedure for removing the dash? Thanks.
On mine, I removed the access panel on top, the ethernet is right there plugged into the optiview screen. Unplug, wait 15 minutes and plug in. If that does not do it, and probably will not, its the viper module
__________________
2021 Newmar Ventana 4369 Freightliner Chassis
2020 Chevy Blazer Toad
Winger2 is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dometic refrigerator not working but freezer is working traw7 Forest River Owners Forum 6 09-03-2021 09:19 AM
Norcold fridge working, but not working EdNope RV Systems & Appliances 15 08-30-2017 11:16 AM
Slide not working / motor is working chrisc8869 5th Wheel Discussion 5 08-15-2015 07:24 PM
Dash AC vents not not working 2002 Ambassador Vipeoc Class A Motorhome Discussions 9 10-02-2013 03:02 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 05:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.