RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-29-2020, 01:33 PM   #1
Senior Member
 
Join Date: Sep 2017
Location: Boston
Posts: 518
Dead Silverleaf modules: the charge bridge solenoid diode

I'm creating a new thread dedicated to this because I think it deserves it and I want to make sure people know about it ...

If you have a White-Rogers solenoid for your charge bridge, you'll at least want the $30 kit from Silver Leaf to add a diode that protects against voltage spikes, because these spikes are destroying Silverleaf modules. My TM-102, while it hasn't been destroyed (yet), has acted up a few times requiring a reboot. However, most recently my TM-250 (EMS) has been damaged -- I have stuff like Oasis AC-1 and a Floor Heat zone that's being load shed and neither I nor Silverleaf support could fix it (even with my Omniscope). We actually made it worse when we tried to fix it (it load shed almost everything). I've temporarily disconnected the TM-250 to disable all load-shedding so I can use the stuff in my RV ... in the meantime, I'm paying $125 for a refurbished (90 day warranty) TM-250 replacement ($250 brand new, 1 year warranty) and $30 for the diode kit.

I've had the most problems when I'm charging from the generator and not shore power. Indeed I was dry camping for a month and that's when the TM-250 died and when I had the most frequency of requiring a TM-102 reboot.


For reference:
https://www.irv2.com/forums/f103/new...ml#post5320356
https://www.irv2.com/forums/f103/no-...ls-489901.html
__________________
2018 Newmar New Aire 3343 | 2020 Tesla Model 3 | Aluma 8216Tilt Trailer
cinergi is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-29-2020, 02:30 PM   #2
Senior Member
 
Jtrving's Avatar


 
Join Date: Mar 2017
Location: Roaring Gap, NC
Posts: 539
Dead Silverleaf modules: the charge bridge solenoid diode

Wow, I was going to post the exact same thing later this week. My diode is coming from Silverleaf this week. This is really unbelievable. Iím glad I caught it before the real damage was done!

My only issue so far was the Silverleaf showing the house batteries at 0V, but the Silverleaf tech told me some horror stories that he has heard from other customers.

For the record, this happened ONLY while on shore power.
__________________
Jeff & Tracie (Stella & Hoonah - the rescue mutts)
2018 Mountain Aire 4531
2013 Jeep Wrangler Sport
Jtrving is offline   Reply With Quote
Old 06-29-2020, 03:26 PM   #3
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2017
Posts: 651
I've had this problem popup a few times. The KIB water pump button wouldn't work even though the relay on the KIB control board in the rear closet was clicking. I found out from Silverleaf that the KIB system actually sends a signal to the TM102 which then activates a relay on a KIB relay board in the electrical bay. Pulling the MAIN connector on the TM102 to reboot the device resolved the problem (at least until it happened again). I haven't had the problem in occur in around 6 months.

So where does the diode fit in the electrical flow? Can you provide a Newmar or Silverleaf part number? Or is there a specific diode I can go buy and install? As always - any pictures?
flyboy013 is online now   Reply With Quote
Old 06-29-2020, 08:37 PM   #4
Senior Member
 
Join Date: Sep 2017
Location: Boston
Posts: 518
I believe the diode goes across the solenoid terminals. I just ordered the parts today. Will post pictures once I get going.
__________________
2018 Newmar New Aire 3343 | 2020 Tesla Model 3 | Aluma 8216Tilt Trailer
cinergi is offline   Reply With Quote
Old 06-30-2020, 06:00 AM   #5
Senior Member
 
Coral's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Jul 2016
Posts: 642
Quote:
Originally Posted by cinergi View Post
I believe the diode goes across the solenoid terminals. I just ordered the parts today. Will post pictures once I get going.

Thanks, I'm looking forward to pictures and how to install.
__________________
Terry & Sue
2015 Newmar Essex 4553 with Spartan K3
2016 Wrangler using Ready Brute Elite
[SIGPIC][/SIGPIC]

Coral is online now   Reply With Quote
Old 07-06-2020, 12:15 AM   #6
Senior Member
 
Join Date: Sep 2017
Location: Boston
Posts: 518
Quote:
Originally Posted by Coral View Post
Thanks, I'm looking forward to pictures and how to install.
Made a video: https://youtu.be/HsYb-1nT8Zs
__________________
2018 Newmar New Aire 3343 | 2020 Tesla Model 3 | Aluma 8216Tilt Trailer
cinergi is offline   Reply With Quote
Old 07-06-2020, 09:46 AM   #7
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,443
Thanks for the thread, cinergi, I will add to the Silver Leaf section of this thread.
I had the reboot thread but will add this also.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 07-08-2020, 07:22 AM   #8
Member
 
Join Date: Jul 2018
Location: Cleveland, OH
Posts: 90
NEW AIRE Charging Bridge Diode

Quote:
Originally Posted by cinergi View Post
Is the Diode part number you ordered the HA-WR01 that was written on the bag in the video? I called Newmar this morning and they could not provide any information on it. Or did you get it from Silverleaf?
__________________
Bob & Jill
Cleveland, OH
2018 3343 New Aire
BPeas is offline   Reply With Quote
Old 07-08-2020, 07:29 AM   #9
Senior Member
 
Join Date: Sep 2017
Location: Boston
Posts: 518
Quote:
Originally Posted by BPeas View Post
Is the Diode part number you ordered the HA-WR01 that was written on the bag in the video? I called Newmar this morning and they could not provide any information on it. Or did you get it from Silverleaf?

Thatís the right part number but yeah itís from silverleaf unlike what I said in the original post. Sorry about that.
__________________
2018 Newmar New Aire 3343 | 2020 Tesla Model 3 | Aluma 8216Tilt Trailer
cinergi is offline   Reply With Quote
Old 07-08-2020, 08:37 AM   #10
Member
 
Join Date: Jul 2018
Location: Cleveland, OH
Posts: 90
Quote:
Originally Posted by cinergi View Post
Thatís the right part number but yeah itís from silverleaf unlike what I said in the original post. Sorry about that.
Appreciate the quick response. Iíll reach out to Silverleaf now before I have any other problems.
__________________
Bob & Jill
Cleveland, OH
2018 3343 New Aire
BPeas is offline   Reply With Quote
Old 07-08-2020, 10:49 AM   #11
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,443
Corrected part to Silver Leaf, not Newmar.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 07-08-2020, 02:15 PM   #12
Senior Member
 
Join Date: Nov 2006
Location: Utah
Posts: 252
Thanks for all you do for the rest of us 007 and cinergi; we really appreciate it!


Anybody know if this also applies to the 2020 New Aire? I can't find anything on Newgle on the relay.
__________________
2020 Newmar New Aire 3543
SteveR is offline   Reply With Quote
Old 07-08-2020, 06:56 PM   #13
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2017
Posts: 651
For those of you who would prefer making their own, I traded emails with Silverleaf the other day and got the following response when I asked which diode was being used and whether I could use a 1N4001 diode.

Quote:
You want a Diode that can handle the Voltage from the Fly Back...
We're using the SD840. The 1N4001 is fairly Close in Parameters to the SD840.
I have not yet wired up one for my coach.
flyboy013 is online now   Reply With Quote
Old 07-08-2020, 10:27 PM   #14
Junior Member
 
Join Date: Dec 2016
Location: California, Texas, Ontario
Posts: 8
Hey guys.... i have a 2017 king aire... in the multiple trips each year... we have had one smooth one so far... but right now... the rv is in the shop right now with silver leaf issues.... and they canít fix it or figure it out... not sure if this could be a similar issue....

Originally no issue it has always been plugged in drove to California (our one smooth trip no issue) and was there plugged in for 2 weeks... just before we left... while still plugged in silver leaf started reading yellow... and house batteries 0... but everything worked... called newmar they said to pull fuses for inverters... fixed the issue... got 60 miles out of the drive way and it did it again while driving.... so pulled over and tried the same thing and everything went crazy... dash wouldnít work with silver leaf on.... if i unplugged the left end plug of the tree of plugs behind the dash... (turned the silver leaf off, no cameras, AC anything, but the chassis stuff for the dash would read... wouldnít all work right but the numbers would read... when we stopped... plugged that back in the house would work and silver leaf no issue but couldnít drive like that b/v air and speedometer and air wouldnít read... so still in the shop they thought it was module 350... replaced that for 1200$ But it[s still not working... Iíve heard nothing but good things about newmar but really ours has been a HUGE pain... not sure if these issues sound familiar but maybe i can tell them about this to see if it helps!

Thanks!
burnzie88 is offline   Reply With Quote
Reply

Tags
solenoid



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charge Bridge Solenoid Help ewlee Newmar Owner's Forum 14 09-02-2018 05:55 PM
Charge Bridge Solenoid Part Number?? jd956jd956 Newmar Owner's Forum 3 07-27-2018 09:40 AM
Question about LSL toad charge... Is a diode needed? ajlcal Toads and Motorhome Related Towing 4 01-13-2016 02:28 PM
Does 12V Charge Wire Need Diode kennersonf Toads and Motorhome Related Towing 17 04-15-2013 12:17 PM
VANSCO VMM 2820 Modules Bruce & Elaine Daniels MH-General Discussions & Problems 5 12-22-2008 07:48 AM


All times are GMT -6. The time now is 08:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.