RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-20-2017, 06:58 PM   #1
Junior Member
 
dwatson8841's Avatar
 
Join Date: Jul 2015
Location: Mobile, AL
Posts: 18
Dometic E7 Code on Generator Only

Spent several days camped this past week, A/C worked flawlessly. We have had our 2012 Mountain Aire for about a year and still learning!!! On the drive home this morning both the dash air and house air went out. Two separate problems, i know, but what a coincidence.

Dash air can probably be fixed with a coolant charge but the house air is giving me an E7 code while on generator power. If I turn the generator off and connect shore power, all is well and all three units work as they should. I have checked the circuit breakers but the circuit has to be intact for the units to work on shore power. Why are the units not receiving 110v power from the generator?

Great forum!!! Thanks
__________________

dwatson8841 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-21-2017, 05:33 AM   #2
Member
 
Hugh Jass's Avatar
 
Join Date: Nov 2016
Location: Katy, Texas
Posts: 54
Quote:
Originally Posted by dwatson8841 View Post
Spent several days camped this past week, A/C worked flawlessly. We have had our 2012 Mountain Aire for about a year and still learning!!! On the drive home this morning both the dash air and house air went out. Two separate problems, i know, but what a coincidence.

Dash air can probably be fixed with a coolant charge but the house air is giving me an E7 code while on generator power. If I turn the generator off and connect shore power, all is well and all three units work as they should. I have checked the circuit breakers but the circuit has to be intact for the units to work on shore power. Why are the units not receiving 110v power from the generator?

Great forum!!! Thanks
Have your checked the top of the Generator? There is a circuit breaker there.
__________________

__________________
----
Todd and Laurie
2018 DSDP 4362 Spartan < = 2016 Ford Edge
Hugh Jass is offline   Reply With Quote
Old 08-21-2017, 05:47 AM   #3
Junior Member
 
dwatson8841's Avatar
 
Join Date: Jul 2015
Location: Mobile, AL
Posts: 18
Yes, reset all house breakers including the one on the generator. Is there a breaker associated with the invertor?
dwatson8841 is offline   Reply With Quote
Old 08-21-2017, 06:51 AM   #4
Member
 
Hugh Jass's Avatar
 
Join Date: Nov 2016
Location: Katy, Texas
Posts: 54
Quote:
Originally Posted by dwatson8841 View Post
Yes, reset all house breakers including the one on the generator. Is there a breaker associated with the invertor?

Yes, but I don't see how this is the issue. For peace of mind you can find your inverter and make sure it's not tripped. No idea where it is in your coach... Mine is attached to a frame rail in the middle of the basement, pretty easy to get to, just have to crawl back in there.

Are you getting ANY AC power when the generator is on? Easy to check, just find something that doesn't run off the inverter and turn it on. I monitor my AC power from my engine block heater when it's in storage to know if the power goes out at the storage place.

If you are getting AC from shore power, but not from Genset, and all your breakers are set right... Transfer switch would be where I'd look next.... But, we have just gone past my knowledge base. Someone smart will come along and offer better advice I'm sure.
__________________
----
Todd and Laurie
2018 DSDP 4362 Spartan < = 2016 Ford Edge
Hugh Jass is offline   Reply With Quote
Old 08-21-2017, 12:59 PM   #5
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: Foley AL
Posts: 7,124
Quote:
Originally Posted by Hugh Jass View Post
Yes, but I don't see how this is the issue. For peace of mind you can find your inverter and make sure it's not tripped. No idea where it is in your coach... Mine is attached to a frame rail in the middle of the basement, pretty easy to get to, just have to crawl back in there.

Are you getting ANY AC power when the generator is on? Easy to check, just find something that doesn't run off the inverter and turn it on. I monitor my AC power from my engine block heater when it's in storage to know if the power goes out at the storage place.

If you are getting AC from shore power, but not from Genset, and all your breakers are set right... Transfer switch would be where I'd look next.... But, we have just gone past my knowledge base. Someone smart will come along and offer better advice I'm sure.
This just happened to me. Transfer switch failed. Genset is fine and I have a fault light on the Transfer switch. The default position for the switch is Shore Power. With a fault, the switch goes to default and disconnects the genset. Switch is on order ...
__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Reply

Tags
dometic, generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Class A Only / Adults Only az99 Class A Motorhome Discussions 61 07-01-2016 06:54 AM
Chevy P30 EGR (Code 32) only while driving micoviso Workhorse and Chevrolet Chassis Motorhome Forum 11 08-21-2015 08:50 PM
Whirlpool Washer throws F:07 Fault Code BUT only on Generator? danleininger Newmar Owner's Forum 51 10-18-2014 08:25 AM
Fail code 6942 only 2000 Damon Allison Transmission Forum 5 07-17-2012 08:48 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×