Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-27-2019, 12:40 AM   #1
ARD
Senior Member
 
ARD's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2017
Posts: 464
Entrance Lock Switch Problem

Yesterday I realized that my entrance lock switch will only operate on the basement doors. It stopped locking/unlocking the front door. Anyone have any clues what the issue may be?

Thanks for your help!

Renee
__________________
Renee (and Alfie & Sophie, Coton du Tulears)
2018 DSDP 4369 -> 2022 LA 4551 on order
2017 GMC Yukon Denali
ARD is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-27-2019, 06:30 AM   #2
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2014
Location: Lake McClure, CA
Posts: 1,313
Last week my compartment door locks stopped working and the entrance door did work. It was a blown fuse, would think yours may be the opposite. My compartment door fuse was in the first bay on drivers side.
__________________
2018 Dutch Star 4369 Spartan Chassis
2016 Jeep Cherokee, 1952 Willys CJ3A
10 fan is offline   Reply With Quote
Old 07-27-2019, 07:56 AM   #3
Registered User
 
Newmar Owners Club
Appalachian Campers
Freightliner Owners Club
Join Date: Feb 2017
Location: Midlothian, VA
Posts: 4,774
Quote:
Originally Posted by ARD View Post
Yesterday I realized that my entrance lock switch will only operate on the basement doors. It stopped locking/unlocking the front door. Anyone have any clues what the issue may be?

Thanks for your help!

Renee
I just took a gander through my Trimark manual and it wasn't much help and I'm also not sure we have the same systems, most likely do. I actually had my handle replaced at my 1 year warranty but that was because the backlighting wasn't working properly on the lower keys. I dread the day that thing doesn't work as I do depend on it although I keep spare keys in two other locations (I had extras made).

As to your issue...what I personally would do for analysis:

1) If you press and hold the 1 key does it always work to LOCK all of the locks? This would tell me if the key is working on the keypad

2) Enter your 5 digit code, pause a second, press the 1 key. What happens?

3) Repeat above with the 2 key, what happens? Then the 4 key?

Mine are programmed as (after combo) 1 key is entry door only, 2 key is basement locks only, 4 key is both entry door and basement.

Does the remote key fob work? Try with the entry door, then the cargo doors, this will also help see if there is any pattern to what's working vs. not.

I don't know if a power cycle of that system would help. I suggest looking at your electrical diagrams of your fuses to find the fuse for that system, pull it and reinsert it to reboot it and see if that does anything to fix the problem.

Lastly...call Newmar, they would conference you to Trimark as needed but I can hear them now pointing you to fuses. A good diagnosis of what's working or not would be first in my analysis.
NealC is offline   Reply With Quote
Old 07-27-2019, 09:02 AM   #4
Senior Member
 
Stuart W's Avatar


 
Newmar Owners Club
Join Date: Nov 2015
Location: LA CA
Posts: 6,214
Hi Renee, remember the fuses in the electric pay have lights next to them, light on indicating a blown fuse. Seems like a good starting point. Are we talking the handle and remote?
__________________

2018 Dutch Star 4369 Spartan!
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 07-27-2019, 09:24 AM   #5
Member
 
Newmar Owners Club
Join Date: Nov 2018
Posts: 70
Mine also started with just locking and unlocking only the basement doors and not controlling the entry door lock. What works for mine is shutting off the 12 volt switch in overhead we're are tank level gauge and other controls are. Leave off for a couple minutes and it resets entry door and it works normal.
Carl 2014 dutchstar 4364
Greenbarn1 is offline   Reply With Quote
Old 07-27-2019, 09:52 AM   #6
Senior Member
 
Join Date: Sep 2010
Posts: 4,170
A couple months ago we had to replace the front door lock motor on the LA. Had to take door plate off and replaced 12 volt door locking motor. Motor came with metal bracket for motor which we didn't need because it could have been taken off other motor and paid 120$. Once I checked it all out we purchased 4 electric door lock replacement motors for 25$. Sounds like that is what your problem is because that is just what are problem was.
Newmar Man
__________________
Tom/Teri 16031 NKK 117995 FMCA
18 London Aire 4531 Spartan K-3 605
97-04 LA 04-18 Essex 2018 London Aire
tom chelbana is offline   Reply With Quote
Old 07-27-2019, 12:26 PM   #7
Senior Member
 
plane's Avatar
 
Newmar Owners Club
Join Date: Sep 2005
Location: Tulsa, OK
Posts: 678
Quote:
Originally Posted by NealC View Post
I just took a gander through my Trimark manual and it wasn't much help and I'm also not sure we have the same systems, most likely do. I actually had my handle replaced at my 1 year warranty but that was because the backlighting wasn't working properly on the lower keys. I dread the day that thing doesn't work as I do depend on it although I keep spare keys in two other locations (I had extras made).

As to your issue...what I personally would do for analysis:

1) If you press and hold the 1 key does it always work to LOCK all of the locks? This would tell me if the key is working on the keypad

2) Enter your 5 digit code, pause a second, press the 1 key. What happens?

3) Repeat above with the 2 key, what happens? Then the 4 key?

Mine are programmed as (after combo) 1 key is entry door only, 2 key is basement locks only, 4 key is both entry door and basement.

Does the remote key fob work? Try with the entry door, then the cargo doors, this will also help see if there is any pattern to what's working vs. not.

I don't know if a power cycle of that system would help. I suggest looking at your electrical diagrams of your fuses to find the fuse for that system, pull it and reinsert it to reboot it and see if that does anything to fix the problem.

Lastly...call Newmar, they would conference you to Trimark as needed but I can hear them now pointing you to fuses. A good diagnosis of what's working or not would be first in my analysis.
When I picked up my unit I was told Newmar no longer has the program that allows the use of the 1 for for door and 3 for bays. I really missed that function.
__________________
Jim Mefford
2018 New Aire 3343
plane is offline   Reply With Quote
Old 07-27-2019, 01:33 PM   #8
Senior Member
 
Tizbad's Avatar
 
Join Date: Apr 2012
Location: Il
Posts: 309
I sprayed some WD40 on a paper towel and wiped off the brass contacts on the door and the "plungers" that make contact with the door. All has been well ever since. These contacts are between the hinges. You'll see them with the door open.
__________________
Safe travels!

2016 4519 Newmar Essex / AWD Ford Explorer
Tizbad is offline   Reply With Quote
Old 07-27-2019, 06:07 PM   #9
ARD
Senior Member
 
ARD's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2017
Posts: 464
Thank you everyone! I love this forum. I forgot about the fuses so when 10 Fan mentioned it, I checked it and it wasn't blown, so I just put it back in. Still didn't work, so I goofed off today and when I got back to the coach, I changed the fuse anyway and HOORAY...it's all working again. Thank you for all the suggestions and help. I'll keep in mind the WD40 and battery disconnect next time too.
__________________
Renee (and Alfie & Sophie, Coton du Tulears)
2018 DSDP 4369 -> 2022 LA 4551 on order
2017 GMC Yukon Denali
ARD is offline   Reply With Quote
Old 07-27-2019, 06:09 PM   #10
ARD
Senior Member
 
ARD's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2017
Posts: 464
Quote:
Originally Posted by Stuart W View Post
Hi Renee, remember the fuses in the electric pay have lights next to them, light on indicating a blown fuse. Seems like a good starting point. Are we talking the handle and remote?


Eeeks! I forgot to look for lights. I just pulled the bugger out. I'll be more savvy next time.
__________________
Renee (and Alfie & Sophie, Coton du Tulears)
2018 DSDP 4369 -> 2022 LA 4551 on order
2017 GMC Yukon Denali
ARD is offline   Reply With Quote
Old 07-27-2019, 06:12 PM   #11
Registered User
 
Newmar Owners Club
Appalachian Campers
Freightliner Owners Club
Join Date: Feb 2017
Location: Midlothian, VA
Posts: 4,774
Ya dun guud!

I think those contacts (WD40) are for the stairs and not related to the trimark....
NealC is offline   Reply With Quote
Old 07-27-2019, 08:11 PM   #12
Registered User
 
Join Date: Oct 2016
Posts: 2,078
Quote:
Originally Posted by Tizbad View Post
I sprayed some WD40 on a paper towel and wiped off the brass contacts on the door and the "plungers" that make contact with the door. All has been well ever since. These contacts are between the hinges. You'll see them with the door open.
Really better to lightly buff them with crocus cloth or fine emory cloth and ot spray with a dielectric but use a contact cleaner or nothing
lwmcguire is offline   Reply With Quote
Old 07-27-2019, 08:12 PM   #13
Registered User
 
Join Date: Oct 2016
Posts: 2,078
Quote:
Originally Posted by NealC View Post
Ya dun guud!

I think those contacts (WD40) are for the stairs and not related to the trimark....
For both on the Tuscany, don't know about yours
lwmcguire is offline   Reply With Quote
Reply

Tags
problem, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Winnebago View Entrance Door Lock ko4nrbs Winnebago Industries Owner's Forum 2 01-08-2014 08:40 PM
Entrance door lock for Baystar? Paul.Gitter Newmar Owner's Forum 1 06-08-2012 08:25 AM
Paddle lock on entrance door Chaffeekid Fleetwood Owner's Forum 7 05-21-2012 06:15 AM
Entrance Door Lock not working Al Spivey Winnebago Industries Owner's Forum 1 02-08-2010 09:34 PM
2005 Travel Supreme 42DS04 Deadbolt entrance door lock al.m Travel Supreme Owner's Forum 3 01-11-2010 04:25 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.